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Unable to access appliance Virtual IP / VIP on PureData System for Analytics

Troubleshooting


Problem

Access to appliance by host IP is fine but VIP / public virtual IP is not responding

Symptom

Ping , SSH , ODBC connections to the VIP fail. Access to the host over the host IP address works fine.

Cause

VIP is not active, cluster services not running or VIP is active on both / hosts

Environment

Netezza PureData System for Analytics clustered systems

Diagnosing The Problem

If cluster is up and running the cibadmin command can be of help here..

# service heartbeat status


heartbeat OK [pid 4710 et al] is running

Find out what interface is used for the VIP

# cibadmin -Q | grep -i wall


<primitive class="ocf" provider="heartbeat" type="IPaddr" id="wall_ip">
<instance_attributes id="wall_ip_ext_config">
<nvpair name="ip" id="wall_ip_ext_attr_1" value="192.168.2.5"/>
<nvpair name="netmask" id="wall_ip_ext_attr_2" value="24"/>
<nvpair id="wall_ip_ext_attr_3" name="nic" value="eth12"/>

From this output we know that the interface used for the VIP is eth12 , the ip address is 192.168.2.5 and the subnet mask is 24 (255.255.255.0)

Checking the status of the interfaces



[root@Netezza-H1 ~]# ifconfig | grep eth12
eth12 Link encap:Ethernet HWaddr 40:F2:E9:9D:38:02

We can see that only one interface for eth12 exists. The vip would be eth12:0 and would show here as well if up and running.

Checking the other host...

[root@Netezza-H1 ~]# ssh ha2 ifconfig | grep eth12
eth12 Link encap:Ethernet HWaddr 40:F2:E9:9D:38:FA

We now know that the VIP is not active on either host.

If heartbeat is not running. The VIP would need to be brought up manually as there is no service to bring the VIP up automatically in non-cluster mode.

Resolving The Problem

On the active host that is running the NPS database service and using the information provided by the cibadmin -Q command...

As root user


# ifconfig eth12:0 192.168.2.5 netmask 255.255.255.0 up

This will manually bring up the VIP interface. Depending on the network infrastructure this IP address should be pingable in a short period of time.

The VIP should only be running on the active host. If it is running on both hosts , each host will constantly tell the network switches that it owns the IP and connectivity will be hit or miss.

To take down the VIP if it is on the incorrect host issue the command as root..
# ifconfig eth12:0 down

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSULQD","label":"IBM PureData System"},"ARM Category":[{"code":"","label":""}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0"},{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSUSQ8","label":"IBM Netezza Analytics"},"ARM Category":[{"code":"","label":""}],"Platform":[{"code":"","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
03 June 2022

UID

swg21981037