Troubleshooting
Problem
Unable to register server license after upgrading the server.
Symptom
REGISTER LICENSE command may fail with:
ANR9638W: License registration is not supported on this server.
Cause
Missing or incorrect versions of the Server's license files.
Diagnosing The Problem
Registering server license may fail with the following warning:
ANR9638W: License registration is not supported on this server.
The actlog may show messages like:
ANR2841W: Server is NOT IN COMPLIANCE with license terms.
Issuing “query license” may show server license compliance as failed:
Is Tivoli Storage Manager Extended Edition licensed: No
Server License Compliance: FAILED
Resolving The Problem
The warning can occur for the following reasons:
- The adsmlicn.dll and/or dataret.lic, tsmbasic.lic, and tsmee.lic are missing from the server directory.
- The files listed above exist, but are not from the correct version of the server.
To resolve this issue, download the base code for the version installed (6.3.0.0, or
7.1.0.0 package for example) and re-run the installation; it is only necessary to select the
license file for installation. Once that completes, issue the command:
register license file=*lic
More information about the Register License command can be found here:
https://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.4/srv.reference/r_cmd_license_register.html
Alternatively, copying the missing files from the base installation package can resolve the issue.
In some cases a reboot of the system is needed following the placement of the correct license files into the correct directory.
Product Synonym
TSM
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21980436