IBM Support

Decision Center: Database export utility

Troubleshooting


Problem

Decision Center is not behaving as expected and you need to share the data with customer support for diagnostic.

Symptom

Using Decision Center, you are facing problems managing releases, deploying a decision service, or performance is slower than usual.

Cause

Logs may be insufficient to diagnose a problem and the support team needs to use the database to reproduce the problem.

Resolving The Problem

This webapp creates a .zip file with the content of a Decision Center repository.
Optionally, it can exclude the rule definitions to help address privacy concerns, while still reproducing most repository issues.
The webapp must be deployed on a server where a Decision Center datasource is configured. It can typically be deployed alongside the Decision Center web application.

Note: This application does not communicate with or depend on Decision Center. It uses the datasource directly and can therefore be used to export the database from any version of Decision Center.
 

Installation


You can skip this chapter if you are using ODM on containers (ODM on kubernetes or ODM on CP4BA) as the required WAR file is already deployed in Decision Center container image.
As for ODM on premise, the required steps below only need to be done once:
  1. Download this file decisioncenter-dbdump.war_.zip
  2. Unzip decisioncenter-dbdump.war_.zip and extract decisioncenter-dbdump.war
  3. Deploy decisioncenter-dbdump.war.
    For example, on Liberty, copy the war file to the apps directory (eg. C:\IBM\wlp\usr\servers\odm81050\apps)
  4. Map the rtsAdministrator role to users/groups.
    For example, on Liberty, add the following in the server.xml:
    	<!-- DB dump -->
    	<application type="war" id="decisioncenter-dbdump" name="decisioncenter-dbdump"
    		location="${server.config.dir}/apps/decisioncenter-dbdump.war">
    		<classloader delegation="parentLast" />
    		<application-bnd>
    		<security-role name="rtsAdministrator">
    		<group name="AdminGroup" />
    		</security-role>
    		</application-bnd>
    	</application>

Note: The webapp uses BASIC authentication, so make sure to map the rtsAdministrator role during deployment. If needed, it is possible to disable security by commenting out the bottom section of the WEB-INF/web.xml file (i.e, <security-constraint> ....</security-role> ).
 

Usage


Web page:
  1. Browse to http://<hostname or IP>:<port>/decisioncenter-dbdump
  2. Provide the JNDI name for the datasource. The default suggested value is jdbc/ilogDataSource.
  3. Optionally, click on the Lookup button to get some information on the datasource.
  4. Provide the schema name for the Decision Center schema.
    The option to "use data source default" means that the same schema name as computed by the Decision Center application will be used to retrieve the tables.
  5. Select the check box "Exclude definitions" if you prefer excluding rule definitions.
  6. Generate the zip file using one of the following options:
    1. Click "Direct download" and a .zip download starts shortly.
      No file is saved on the server.
    2. Click "Save on server" and the export is generated on the server.
      When the export is complete, a link is shown.

Direct URL:

A URL can be used to initiate the download. It should be of the form:
http://<hostname or IP>:<port>/decisioncenter-dbdump/services/download?<parameters...>

The parameters are:
  • ds: The data source JNDI name (e.g. ds=jdbc/ilogDataSource)
  • schemaName: The name of the schema (e.g. schemaName=ODMDB)
  • excludeDefinitions: Request to exclude definitions with excludeDefinitions=true
  • useDefaultSchemaName: Request to use the default schema name with useDefaultSchemaName=true

For example, with curl on Windows assuming the host is localhost and the http port is 9080:
curl -u rtsAdmin:rtsAdmin -o dbdumpWithCurl.zip http://localhost:9080/decisioncenter-dbdump/services/download?useDefaultSchemaName=true&ds=jdbc/ilogDataSource
 

Troubleshooting


If you have an issue with this tool and an exception is thrown, it should be shown in the same web page that was used to initiate the export (refresh your browser if needed):
    http://<host>:<port>/decisioncenter-dbdump
If the export does not complete and no error message is shown in the user interface, check the application server log.
Whenever possible, if an exception occurred during the export, a file "error.txt" is saved in the generated .zip archive. This can be useful when initiating the export from the command line.
With direct URL, if an error occurred but a zip can still be retrieved, checking for "error.txt" can help troubleshoot the issue.

If further diagnostic trace is needed, the JDK logging of the JVM/Application server should be configured with FINER level trace for the package:
ilog.rules.teamserver.dbdump.*
 

Note on Java 2 Security


When Java 2 Security is enabled on the WebSphere Application Server, the option to "Save on server" will fail with an exception such as
java.security.AccessControlException:
Access denied ("java.lang.RuntimePermission" "modifyThreadGroup")

There are two options to resolve the issue:
  • Fallback on the option to "Direct download"
  • Make sure to deploy a JavaEE application decisioncenter-dbdump.ear that wraps the decisioncenter-dbdump.war with an application containing a was.policy file that grants access to the resources needed.

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSQP76","label":"IBM Operational Decision Manager"},"ARM Category":[{"code":"a8m50000000L36nAAC","label":"Decision Center"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"},{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSQP76","label":"IBM Operational Decision Manager"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
01 December 2022

UID

swg21980378