IBM Support

StoredIQ Unable to login to AppStack UI

Troubleshooting


Problem

I am unable to login to my AppStack UI with any account

Symptom

Unable to login to the AppStack UI via superadmin account and any other admin account

Cause

If you are unable to login to the AppStack UI because you have forgotten/misplaced/recently changed passwords for these accounts proceed to section 'Resolving The Problem'. Otherwise proceed to steps directly below.

If you are sure the passwords entered are correct these issues can be caused either by :
A) Some StoredIQ services not functioning correctly
B) Storage capacity issues.

Environment

StoredIQ AppStack
StoredIQ DataServer if storage capacity is the issue

Diagnosing The Problem

To check if services are the cause of the issue:
1) Open a SSH session to your AppStack via Putty and login as root
2) Run the command /siq/bin/monit summary
3) Make sure all services listed as 'Running'
4) If any services are NOT 'Running' then proceed to section 'Resolving The Problem'


To check if storage capacity is the issue:
1) Open a SSH session to your DataServer via Putty and login as root
2) Run the command : df -h (this command will show you the current storage utilization)
3) Examine and make sure Storage Use % are not 100% on the large filesystems
4) If storage levels are full or if you are unsure, please contact IBM support for next steps as the cause to why it is full can differ

Resolving The Problem

If you have forgotten your admin account passwords, you may reset the 'superadmin' password in the AppStack shell and then use that account to login to reset other admin account passwords:
1) Open an SSH session to your AppStack via Putty and login as 'root'
2) Run the command : /siq/bin/change_superadmin_password
3) You will be prompted to enter a 'strong' password of at least 8 characters, upper and lower case, one numeric, one special character
4) Once you have reset your password, go ahead and wait a few minutes and then login to your AppStack UI with the superadmin account
5) From here you may proceed to the 'Accounts' page and reset any other account passwords you may need

If any AppStack services are not listed as running, restart all AppStack services:
1) Open an SSH session to your AppStack and login as 'root'
2) Run the following to restart services : /siq/bin/monit restart all
3) Wait a few minutes for services to restart
4) Check and see if all services are up and running by entering the command : /siq/bin/monit summary
5) If all services are up and running try logging into AppStack UI again
6) If services fail to come up, run the following command: /siq/bin/monit reload
7) Check and see if all services are up and running by entering the command : /siq/bin/monit summary
8) If services fail to come up again, run the following command: /siq/bin/monit validate
9) Check and see if all services are up and running by entering the command : /siq/bin/monit summary
10) If services fail to come up again, please stop and start each individual service that is not running, using the command:
/siq/bin/monit stop service_name
/siq/bin/monit start service_name
11) Check and see if all services are up and running by entering the command : /siq/bin/monit summary
12) If services fail to come up again please check storage use levels (above in section 'Diagnosing the problem')
13) If the above does not work, please contact IBM support and include steps performed

[{"Product":{"code":"SSSHEC","label":"StoredIQ"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Application","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6.0.7;7.6.0.6;7.6.0.5;7.6.0.4;7.6.0.3;7.6.0.2;7.6.0.1;7.6","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21980108