IBM Support

ILMT hardware capacity scan failure due to missing SerialNumber value

Troubleshooting


Problem

ILMT hardware capacity scan fails. The "Run Capacity Scan and Upload Results" fixlet result shows the exit code 3.

Symptom

"Run Capacity Scan and Upload Results" fixlet result shows the exit code 3. Fixlet action history log contains:

---
Failed continue if {exit code of action = 0}
delete "{parameter "homefolder" as string}\checkCapacityScanOutput.vbs"
(...)
---

Cause

In the "tlm_hw_<timestamp>.xml" hardware scan output file the <SerialNumber> value is not set.

---
<ComponentID version="1">
<Manufacturer>###</Manufacturer>
<Product>###</Product>
<Version>###</Version>
<SerialNumber> </SerialNumber>
<Type>###</Type>
</ComponentID>
---

This does not disturb the scan process itself, but causes the scan output evaluation to fail.

Diagnosing The Problem

It can be confirmed with this procedure:

1)
Create a test folder - e.g. "PMR"

2)
Go to "C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\CIT" and copy the "checkCapacityScanOutput.vbs" to the new "PMR" folder.

3)
Go to "C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\CIT\tlm_hw_scans" and copy the "tlm_hw_<timestamp>.xml" to the new "PMR" folder.

4)
Open Windows command line and access the "PMR" folder. Next run:

# cscript //Nologo //B checkCapacityScanOutput.vbs tlm_hw_<timestamp>.xml

and when it finishes then run:

# echo %ERRORLEVEL%

It will return "3" what in the "checkCapacityScanOutput.vbs" script file stands for an issue with machine serial number.

Resolving The Problem

Set machine serial number in BIOS.

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Document Information

Modified date:
26 April 2021

UID

swg21980081