Troubleshooting
Problem
In IBM Sterling B2B Integrator (SBI), huge number of mailbox messages are stuck in the database though mailbox delete service schedule runs to delete the messages.
Symptom
- Cleanup processes are running fine (Index, backup, purge, associateBPsToDoc etc..)
- Mailbox delete service is running but every run only 10000 messages are deleted though there are millions of mailbox messages eligible.
Cause
Diagnosing The Problem
By default the mailbox delete service configured to delete only 10000 messages per run.
Resolving The Problem
Below are the two parameter that control the mailbox message deletion:
- messageDeleteBatchSize=1000 <- This is the purge transaction size. For each 1000 message transaction is committed.
- messageDeleteSize=10000 <- This is no. of messages that will be purged in one execution of MailboxDeleteService
Follow either of the below option to resolve the issue:
1. Edit the mailbox.properties and increase the messageDeleteSize from default 10000 to a higher value.
2. Run the mailbox delete service schedule frequently. If the schedule usually takes 15 minutes to delete the 10000 messages then schedule it to run every 30 minute or every one hour till all the eligible message deleted from database.
Was this topic helpful?
Document Information
Modified date:
08 November 2019
UID
swg21977965