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Cannot login to Cognos Connection. On entering the credentials login goes into infinite loop

Troubleshooting


Problem

Cannot login to Cognos Connection. On entering the credentials login goes into infinite loop.

Cause

Slow Domain Controller that was not able to load balance the request to other equal Domain Controllers

Environment

Cognos 10.2.1 using Active Directory

Diagnosing The Problem

User could access Cognos Connection without any problem if Anonymous access was enabled in Cognos Configuration.

Fiddler trace showed that we are not able to receive a response from the AD.

Resolving The Problem

To support Active Directory Server fail over, you can specify the domain name instead of a specific domain controller in Cognos Configuration.
1. Stop Cognos Services in the right order

2. On the Content Manager Server :
In the configured namespace if the entry of the namespace looks like 125.4.56.98:389 , where 125.4.56.98 is the IP of one domain controller, change the IP to domain
i.e use mydomain.com:389 instead of 125.4.56.98:389.

Note: This change needs to be done on all standby Content Manager Servers as well.

3. Save the configuration and start services in the right order

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21977786