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IBM Enterprise Content Management System Monitor (ECM SM) when Attempting to "Accept" the Client from the Connected Agents View on the Client Administration Page, an "Agent Accept Failed" Error is Received

Troubleshooting


Problem

Installed the Client Agent's CALA_REX for IBM Enterprise Content Management System Monitor (ECM SM), but when Attempting to "Accept" the Client from the Connected Agents View on the Client Administration Page, an "Agent Accept Failed" Error is Received.

Symptom

Installed System Monitor Cala_Rex on a Client Server.

Cause

The Java Cache is preventing the New Client from being accepted on the ECM SM Server.

Diagnosing The Problem

The output from "netstat -a" showed that the Client was Listening on Port 23804 and a connection was
established on Port 23802:
XXX.XXX.XXX.XXX:23804 LISTENING
XXX.XXX.XXX.XXX:53802 <ECM SM Server>:23802 ESTABLISHED

The Client Server shows up in the Connected Agent View on the Client Administration Page in red, but
when attempting to "accept" the Client, an "agent accept failed" error message is received.

Resolving The Problem

Using the following procedures clear the Java Cache on the ECM SM Server:

  1. Stop the Cala_Rex on the Client. (Stop the Cala if it is there, too.)

  2. Remove the Client from the ECM SM Server on the "Connected Agents" View:
    1. Logout of the ECM SM Server.
    2. Stop the ECM SM Server Services
    3. Enter "javaws -viewer" (javaws -viewer)
    4. Select all entries (all System Monitor ones) from the Applications and Resources,
      and then click the "X" (Delete) at the top. (It will turn red (become active) once an
      entry is selected in the list.)
    5. Exit the Java Cache Viewer.

  3. Restart the ECM SM Server Services.

  4. Verify the Client is not present in the "Connected Agents" View

  5. On the Client, start the Cala_Rex.

  6. Verify the Client is now available and "accept" the Client.

[{"Product":{"code":"SSEM9N","label":"Enterprise Content Management System Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"FileNet System Monitor","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.1;5.2;5.2.0.1;5.2.0.2","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21977465