IBM Support

Server upgrade fails with ANRI1055E and Windows Microsoft return code 1618

Troubleshooting


Problem

Upgrading the Tivoli Storage Manager or IBM Spectrum Protect Server to an higher version may end with ANRI1055E because of a failure during uninstallation of the device driver.

Cause

Return code 1618 indicates that another MSI install is running.

Diagnosing The Problem

Going through the installation logs, collected by the following technote:
http://www-01.ibm.com/support/docview.wss?uid=swg21664161

the "tsm_device_uninstall.log" file will shown the following MSI error:

=== Verbose logging started: 05.02.2016 15:29:12 Build type: SHIP
UNICODE 5.00.9600.00 Calling process: C:\Windows\system32\msiexec.exe
===
MSI (c) (D0:84) [15:29:12:349]: Resetting cached policy values
MSI (c) (D0:84) [15:29:12:349]: Machine policy value 'Debug' is 0
MSI (c) (D0:84) [15:29:12:349]: ******* RunEngine:
******* Product: {4FE3703D-6C30-46C0-B450-25CB2346B7ED}
******* Action:
******* CommandLine: **********
MSI (c) (D0:84) [15:29:12:349]: Client-side and UI is none or basic:
Running entire install on the server.
MSI (c) (D0:84) [15:29:15:349]: Failed to grab execution mutex. System
error 258.
MSI (c) (D0:84) [15:29:15:349]: Cloaking enabled.
MSI (c) (D0:84) [15:29:15:349]: Attempting to enable all disabled
privileges before calling Install on Server
MSI (c) (D0:84) [15:29:15:349]: Incrementing counter to disable
shutdown. Counter after increment: 0
MSI (c) (D0:84) [15:29:15:349]: Decrementing counter to disable
shutdown. If counter >= 0, shutdown will be denied. Counter after
decrement: -1
MSI (c) (D0:84) [15:29:15:349]: MainEngineThread is returning 1618
=== Verbose logging stopped: 05.02.2016 15:29:15 ===

Resolving The Problem

Perform the following steps in order to fix the problem:

- re-extract the IBM Spectrum Protect Server fixpack (for example "7.1.4.100-TIV-TSMSRV-WIN.exe") to an empty directory

- check the Windows Task Manager for any other processes running an MSI install ( msiexec.exe ). If any, stop these before start the upgrade/install again

- start the install by double clicking on the install.bat file in that new directory

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21976701