Troubleshooting
Problem
Errors FFQD3142E or FFQP0031E are seen after installing WEX 11 AC. The symptoms include but are not limited to the following:
Symptom
1. Unable to run a simple crawl of a small local file share. After configuring the crawler the following error is produced at crawler startup:
"FFQD3142E An error occurred while initializing SIAPI. Index is null"
2. Unable to run an import. An import is configured but no documents are added to the collection nor are error logs produced.
3. Output of installation verification highlights the following:
"FFQP0031E The parser is started but is not serviceable. There might be resource shortages on the index server."
4. The install log (v11.0.0.1install.log) contains the following:
- com.ibm.es.install.action.SetUpdateInstallVariables#install
$OEE_NLS_PANEL_INSTALL_DATA_LISTNER_PORT_CONFLICT_WARNING$ is
The installation program could not set the port for Data Listener applications because the default Data Listener port (6668) is already in use.
After you complete the installation, you can manually set the Data Listener port on the System page in the IBM Watson Explorer Content Analytics administration console.
Cause
There are instances where certain environments have port number "6668" blocked. In this case, try an unused port number like "3000" as the data listener port.
Diagnosing The Problem
Use the command nestat -a to check the current status of the port on a CMD prompt. (Be sure to run the command prompt as an administrator.)
i.e.
netstat -a | find "6668" |
Resolving The Problem
Regardless, if the port does not seem to be in conflict or blocked, run the following procedure to test if the issues can be resolved:
1. In the Administrative Console UI, go to "System" then "Data Listener"
2. Change the "Data Listener port number" from 6668 to 3000
3. Restart WCA/WEX by running esadmin system stopall and then esadmin system startall
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Document Information
Modified date:
17 June 2018
UID
swg21975133