IBM Support

Cognos Report Studio in Tivoli Common Reporting Version 3.1 and later fix packs fail to launch on Internet Explorer Version 11

Troubleshooting


Problem

IBM® Cognos® Report Studio in Tivoli® Common Reporting Version 3.1 and later fix packs fail to launch on Internet Explorer Version 11

Cause

IBM Jazz for Service Management includes the Dashboard Application Services Hub service and the Tivoli Common Reporting service.
Dashboard Application Services Hub supports Internet Explorer v11 in full mode because bundled libraries like Dojo only support Internet Explorer v11 in full mode.
Whereas, the bundled version of Cognos Business Intelligence v10.2.2 within Tivoli Common Reporting supports Internet Explorer v11 in compatibility mode.
When launching Tivoli Common Reporting from Dashboard Application Services Hub, because of browser mode compatibility issues, Cognos Report Studio functionalities do not work as expected.

Resolving The Problem

To resolve this issue, access the following Tivoli Common Reporting dispatcher link:
https://JazzSM_hostname:port/tarf/servlet/dispatch


For example:
https://JazzSM_hostname:16311/tarf/servlet/dispatch

[{"Product":{"code":"SSH2DF","label":"Tivoli Common Reporting"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.1;3.1.0.1;3.1.0.2;3.1.0.3;3.1.1.0;3.1.2.0;3.1.2.1;3.1.3.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21974757