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ANR0151W Database manager fails to start.

Troubleshooting


Problem

The Tivoli Storage Manager (Spectrum Protect ) server fails to start after an upgrade. The ANR0151W message is logged with sqlstate 57019.

Symptom

The following messages are logged when trying to start the server after the upgrade :

ANR7814I Using instance directory /home/tsminst1.
ANR4726I The ICC support module has been loaded.
ANR0990I Server restart-recovery in progress.
ANR0151W Database manager fails to start. For more information about the failure, issue the db2start command.
ANR0171I dbiconn.c(1844): Error detected on 0:1, database in evaluation mode.
ANR0162W Supplemental database diagnostic information: -1:08001:-1032
([IBM][CLI Driver] SQL1032N No start database manager command was
issued. SQLSTATE=57019 ).

Cause

Instance was not updated

Diagnosing The Problem

1. Logon as the instance owner and run the "db2start" command. The command fails with the following messages :

$ db2start
SQL1042C  An unexpected system error occurred.
01/08/2016 08:46:44     0   0   SQL1042C  An unexpected system error occurred.
SQL1032N  No start database manager command was issued.  SQLSTATE=57019


2. The following messages are logged in the db2diag.log file indicating a missing service entry :

2016-01-08-08.50.07.554161-300 I3938A1421 LEVEL: Error
PID : 3407 TID : 17589835726848 PROC : db2bp
INSTANCE: tsminst1 NODE : 000
HOSTNAME: tsm1
FUNCTION: DB2 Tools, DB2 administration server, db2dasGetInstanceInfo,
probe:5
DATA #1 : String, 100 bytes
Error: DB2 instance tsminst1 is missing service entry in global registry.
Some DAS operations may fail.


3. The DB2 registry dump shows the incorrect instance version. For example :

#/opt/tivoli/tsm/db2/bin/db2greg -dump show
V,DB2GPRF,DB2SYSTEM,tsm1,/opt/tivoli/tsm/db2,
I,DB2,10.5.0.5,tsminst1,/home/tsminst1/sqllib,,1,0,/opt/tivoli/tsm/db2,,
V,DB2GPRF,DB2INSTDEF,octsm,/opt/tivoli/tsm/db2, S,DB2,10.5.0.6,/opt/tivoli/tsm/db2,,,6,0,,1452107327,1


Notes :
- The "tsminst1" Instance uses /home/tsminst1/sqllib with a version of 10.5.0.5 which is the old version before the upgrade.
- The service entry at /opt/tivoli/tsm/db2 is at 10.5.0.6 which is the upgraded version.

Resolving The Problem

Login as root and run the "db2iupdt" command to update the instance. For example :

/opt/tivoli/tsm/db2/instance/db2iupdt tsminst1

After the update, verify the db2 registry. Both the instance and the service entries should be at the same level, 10.5.0.6 in this case.
After verifying the levels are correct, login as the instance owner, tsminst1 in this case, and run the following commands :

db2start
db2 connect to tsmdb1

Start the Tivoli Storage Manager server after the above commands complete successfully.

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21974531