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Operation Center logs ANR2034E repeatedly in activity log

Troubleshooting


Problem

The Operation Center administrator id runs a SELECT command on the Tivoli Storage Manager server. The select command logs the ANR2034E message in the server activity log.

Symptom

The Activity log shows the following messages :

ANR0407I Session nnn started for administrator IBM-OC-XXX (DSMAPI) (Tcp/Ip address(port)). (SESSION: nnn)
ANR2034E SELECT: No match found using this criteria. (SESSION: nnn)

Cause

Operation Center setup

Diagnosing The Problem

The Operation Center log (/opt/tivoli/tsm/ui/Liberty/usr/servers/guiServer/logs/tsm_opscntr.log)
shows the following messages :

DsmAdminAPI login Entry, tcpAddress = #.#.#.# , tcpPort = #, portType = TCP, useTLS12Only = false, userId = <admin ID>, password = ***********
....
MacroExecutor execute Executing command: SELECT * FROM SCRATCHPAD WHERE MAJOR='EMAILREPORTS' AND MINOR='EMAIL' AND SUBJECT='DISABLED' ORDER BY LINE $$TSM_NOLOGCMD$$ (more=false, confirm=false)
.....
JsonResultHandler fixResult Entry, result ={"msg":{"n":"2034","s":"E","ins":["SELECT"],"def":"ANR2034E SELECT: No match found using this criteria."}}
....
DsmAdminAPI execute Exit, returnValue = DsmResultBean[rc=11,processNum=0,_resultList is empty,_xmlResults is emptygrouping= decimal= ]
[WARN] There are no recipients defined for the EmailReportsJob
[WARN] EmailReportsJob: Could not send the daily email report

Resolving The Problem

Set up email reporting in Operation Center. The following link explains how to set this up
https://www.youtube.com/watch?v=a7km6bZgGK8

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21974367