IBM Support

Recommending use of Firefox 38 ESR with IBM Notes Browser Plug-in

Flash (Alert)


Abstract

With Mozilla Firefox 43, IBM Notes Browser Plug-in becomes disabled, as it's not verified by Mozilla.

Content

Firefox 43 contains changes to disable any add-on which is not signed and verified by Mozilla.  Due to this, if you have installed the IBM Notes Browser Plug-in, and upgraded to Firefox 43, the add-on will become disabled. Once this happens, you will no longer be able to open Notes content inside Firefox. 
As we work with Mozilla in resolving this, we would strongly recommend that you use the ESR version of Firefox, the latest of which is Version 38.5.2 ESR.

The ESR release does not have the add-on signing enforced for now, and may not have it until Firefox ESR 45, as mentioned in https://wiki.mozilla.org/Add-ons/Extension_Signing
 
This issue has been raised with Mozilla and we will update this note once the issue is resolved.
Bug 1231849 - Extension update fails for disabled side loaded extension (affecting signed extension release) : https://bugzilla.mozilla.org/show_bug.cgi?id=1231849


Recommendation:
1. Ensure you stay on the Firefox ESR release
2. If you want to use a non-ESR version, use Version 42 and disable auto-updates. 
3. Workaround for Firefox 43 :- In about:config set xpinstall.signatures.required=false

Document information

More support for: IBM Notes
Install/Setup

Software version: 9.0.1.5

Operating system(s): Windows

Software edition: All Editions

Reference #: 1974089

Modified date: 04 January 2016