Troubleshooting
Problem
When creating a new Data Module based on a Data Server, there are no schemas listed. Instead "Results are empty" is displayed. The data server can however be successfully tested either when setup or in Administration Console.
Symptom
"Results are empty".
Cause
The connection to the datasource could not be established or accessing metadata, like the list of schemas, failed.
Environment
IBM Cognos Analytics 11
Diagnosing The Problem
"Results are empty" is displayed, instead of listing schemas available in the data server.
Resolving The Problem
One or more of the below list might apply to your environment:
- The connection to the relational datasources requires the appropriate JDBC driver files to be copied into the ..\drivers directory in the main installation directory. This needs to be repeated on every dispatcher with Query Service enabled. A restart of the Cognos Analytics 11 service is required.
- The Oracle 11.2.0.3 ojdbc6.jar was copied into the ../drivers directory, but the "Results are empty" message is still shown. Exchange the ojdbc6.jar with a compatible ojdbc7.jar. A restart of the Cognos Analytics 11 service is required.
- Multiple driver files of the same vendor were copied to the ../drivers location (ie. ojdbc6.jar & ojdbc7.jar for Oracle was present). Make sure only one driver file is present per vendor, and that the driver version file is compatible with Java 8. A restart of the Cognos Analytics 11 service is required.
Related Information
[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21973943