Troubleshooting
Problem
Running Internet Explorer 11 in Compatibility mode is required by business needs, but Maximo does not support Internet Explorer with Compatibility View enabled.
Cause
Maximo Asset Management does not support Microsoft Internet Explorer browsers with compatibility mode enabled. Browsers that have compatibility mode enabled will experience errors and performance issues.
Resolving The Problem
There is an APAR (IV78835) created to fix the Compatibility View issue in Internet Explorer 11. To manually fix, do the following steps:
1) Make a backup of
<maximo_home>\applications\maximo\maximouiweb\webmodule\webclient\login\login.jsp
<maximo_home>\applications\maximo\maximouiweb\webmodule\webclient\components\page.jsp
2) Open login.jsp and page.jsp in a text editor and find the line:
From login.jsp:
<meta http-equiv="Expires" content="0" />
From page.jsp:
<meta http-equiv="Content-Script-Type" content="text/javascript"/>
3) Add this parameter after the line mentioned in step 2:
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
4) Save the file and rebuild / redeploy the EAR.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21973289