IBM Support

ANR0441W error logged during DB2 log archive

Troubleshooting


Problem

A DB2 instance on a Linux system archives its logs to a Tivoli Storage Manager server on an AIX system. The DB2 log archive fails with the ANR0441W error recorded in the activity log of the server.

Symptom

The following messages are recorded in the Tivoli Storage Manager server activity log :

ANR0406I Session 1234 started for node MYDB2NODE (DB2/LINUXX8664) (Tcp/Ip my.tcp.address(nnn)). (SESSION: 1234)
ANR0441W Protocol error on session 1234 for node MYDB2NODE (DB2/LINUXX8664) - invalid data length received. (SESSION: 1234)
ANR0484W Session 1234 for node MYDB2NODE (DB2/LINUXX8664) terminated - protocol violation detected. (SESSION: 1234)


The db2diag.log shows the following messages :

2015-11-11-11.54.28.699335-300 E4438566E431 LEVEL: Info
PID : 14333 TID : 140715073988352 PROC : db2sysc 5
INSTANCE: db2inst NODE : 005 DB : PN1
HOSTNAME: mydb2node
EDUID : 145257 EDUNAME: db2logmgr (PN1) 5
FUNCTION: DB2 UDB, data protection services, sqlpgArchiveLogFile,
probe:3108
DATA #1 : <preformatted>
Started archive for log file S0005678.LOG.
2015-11-11-11.54.32.726133-300 E4440420E390 LEVEL: Error
PID : 15985 TID : 140737009751840 PROC :
db2vend (db2logmgr.meth1 - 14525
INSTANCE: db2inst NODE : 000
HOSTNAME: mydb2node
FUNCTION: DB2 UDB, database utilities, sqluvput, probe:963
DATA #1 : TSM RC, PD_DB2_TYPE_TSM_RC, 4 bytes
TSM RC=0xFFFFFFB8=-72 -- see TSM API Reference for meaning.

Cause

Network issue

Diagnosing The Problem

The ANR0441W message in the Tivoli Storage Manager server activity log indicates there is a problem with the network. For further evidence of a network problem, enable cyclic redundancy check (CRC) validation for data transferred between the Tivoli Storage Manager client and server.
For example, use the following Tivoli Storage Manager server administrative command :

update node MYDB2NODE validateprotocol=all

If the data changes during transfer over the network, the calculated CRC does not match and a Tivoli Storage Manager server API return code 236 is logged in the db2diag.log file on the client. (If you are using the backup-archive client, the message is ANS0342E.)
Also, if the calculated CRC values do not match when using validateprotocol=all, the following message is recorded in the Tivoli Storage Manager server activity log :

ANR1855E Failure validating protocol between client and server for node MYDB2NODE on session 1234 (SESSION: 1234)

In this case, after using validateprotocol=all, the ANR1855E message was logged.

Use a third party tool, such as ftp or sftp, to verify the integrity of the network. In this case, the sftp command also revealed network errors.

Resolving The Problem

The network problem in this case was caused by two faulty switch ports, which were modifying data as it was transferred over the network.
Note:
Updating a Tivoli Storage Manager client nodename with the validateprotocol=all or validateprotocol=dataonly parameter affects performance because of the extra CRC validation that is performed. When the network is determined to be working correctly, update the node again to stop the CRC validation. Use the following Tivoli Storage Manager administrative command :

update node <NODENAME> validateprotocol=no

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21971374