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Configuration of Content Manager v8.5 fp3 fails with extrc=140 soap timeout on rmas component

Troubleshooting


Problem

Configuration of the rmas component of Content Manager fails with extrc=140 soap timeout

Symptom

Configuration of the application server fails.

Cause

Default value of the WebSphere soap timeout is insufficient to complete the request.

Environment

Content Manager v8.5

Diagnosing The Problem

  1. Cmfpconfig.log reports the following:
    2015-11-09 07:29:35.675 stdout: [wsadmin] WASX7017E: Exception
    received while running file "wsadmin.jacl"; exception information:
    com.ibm.websphere.management.exception.ConfigServiceException
    2015-11-09 07:29:35.706 stdout: [wsadmin]
    com.ibm.websphere.management.exception.ConnectorException
    2015-11-09 07:29:35.706 stdout: [wsadmin]
    org.apache.soap.SOAPException: [SOAPException:
    faultCode=SOAP-ENV:Client; msg=Read timed out;
    targetException=java.net.SocketTimeoutException: Read timed out]
    2015-11-09 07:29:35.706 stdout:
    2015-11-09 07:29:35.706 stdout: [wsadmin] WASX7341W: No "save" was
    performed before the interactive scripting session exited;
    configuration changes will not be saved.
    2015-11-09 07:32:36.410 stderr:
    2015-11-09 07:32:36.410 stderr: BUILD FAILED
    2015-11-09 07:32:36.410 ConfigRM: found error
    2015-11-09 07:32:36.410 stderr:
    D:\IBM\db2cmv8\config\configWebApps\configRM.xml:161: The following
    error occurred while executing this line:
    2015-11-09 07:32:36.410 stderr:
    D:\IBM\db2cmv8\config\configWebApps\websphere.xml:65: The following
    error occurred while executing this line:
    2015-11-09 07:32:36.410 stderr:
    D:\IBM\db2cmv8\config\configWebApps\websphere.xml:94: Java returned: 105
    2015-11-09 07:32:36.410 stderr:
    2015-11-09 07:32:36.410 stderr: Total time: 6 minutes 36 seconds
    2015-11-09 07:32:36.410 ExitValue: 1
    2015-11-09 07:32:36.410 rc = 1
    2015-11-09 07:32:36.410 ConfigState Calling writeConfgState()
    2015-11-09 07:32:36.410 SERIALIZE00106 Calling isSerializable()
    2015-11-09 07:32:36.410 DDEBUG:: Trying to delete temp file
    D:\Temp\IBMCM\IBMCMTMP.Administrator2015-11-09_0.TEMP...
    2015-11-09 07:32:36.425 SERIALIZE00107 Exited isSerializable()
    2015-11-09 07:32:36.425 DEBUG:: Writing ConfigState to:
    D:\IBM\db2cmv8\config\install\ConfigState.obj
    2015-11-09 07:32:36.425 SERIALIZE00108 Calling writeObject(Object, File)
    2015-11-09 07:32:36.425 SERIALIZE00109 Exited writeObject(Object, File)
    2015-11-09 07:32:36.425 ConfigState Exited writeConfgState()
    2015-11-09 07:32:36.425 DEBUG:: Configuration state updated
    successfully in file D:\IBM\db2cmv8\config\install\ConfigState.obj.
    2015-11-09 07:32:36.425 ConfigService.writeConfigState(): Information
    in CSO file "D:\IBM\db2cmv8\config\install\ConfigState.obj":
    ====================== Configuration state information
    ======================
    Exit code: 140
    Return code: 0
    Message code:
    Message:

Resolving The Problem

Using the WebSphere administrative console, increase the SOAPConnector timeout value.

  1. Click "Servers > Server Types> WebSphere application servers".
  2. Click the server name in the right pane.
  3. Under Server Infrastructure, click "Administration >Administration Services".
  4. Under Additional Properties, click "JMX connectors", and in the right pane, click "SOAPConnector" in the list.
  5. On the next screen, click "Custom Properties", and then click "requestTimeout" in the list.
  6. Under General Properties, in the Value box, change 600 to 1800. You can choose to change this value back after the configuration is complete.
  7. Click "OK" or "Apply" and then click "Save directly to master configuration".

Note: increase the SOAP request timeout value beyond 1800 if the EAR deployment fails with "the system failed to make the SOAP RPC call: invoke error".

[{"Product":{"code":"SSRS7Z","label":"IBM Content Manager Enterprise Edition"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Upgrading Hints and Tips","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.5;8.5.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21971040