Troubleshooting
Problem
Customer has configured an alert to occur if the "IBM Cognos Controller Consolidation" Windows service (located on the Controller application server) ever stops. Customer is receiving alerts occasionally.
Symptom
Alert description: IBM Cognos Controller Consolidation service stopped unexpectedly on <servername>
Cause
This is by design.
It is only triggered if the customer has manually reconfigured the Windows service 'IBM Cognos Controller Consolidation' to run as 'automatic' (rather than manual').
More Information
From Controller 10.2.0 onwards, the COM+ application "IBM Cognos Controller Consolidation"...
...should be configured to run as a service:
However, it is normal/correct for this service to be set to 'Manual' as shown below:
Also, this service will (almost always) not be 'Running'. This is correct behaviour, because its job is mainly to run consolidations (plus some other rarer tasks), so it is normal for it to spend most of its time not running.
Environment
Customer has manually reconfigured the Windows service 'IBM Cognos Controller Consolidation' to run as 'automatic' (rather than manual'):
Resolving The Problem
This is by design.
Customers should not configure the the Windows service 'IBM Cognos Controller Consolidation' to run as 'automatic'.
- Instead, it should be set to 'manual', and the alert should be removed.
Steps to change the 'startup type':
1. Logon to the Controller application server
2. Open the Windows Services
3. Locate the service 'IBM Cognos Controller Consolidation'
4. Modify its 'Startup Type' to be 'Manual':
5. Disable any alert on the Windows service.
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Document Information
Modified date:
15 June 2018
UID
swg21970970