IBM Support

Security Bulletin: Vulnerability in Apache Commons affects IBM WebSphere Application Server (CVE-2015-7450)

Security Bulletin


Summary

An Apache Commons Collections vulnerability for handling Java object deserialization was addressed by WebSphere Application Server and WebSphere Application Server Hypervisor Edition. This vulnerability does not affect the IBM HTTP Server or versions of WebSphere Application Server prior to Version 7.0.

Vulnerability Details

CVEID: CVE-2015-7450
DESCRIPTION:
Apache Commons Collections could allow a remote attacker to execute arbitrary code on the system, caused by the deserialization of data with Java InvokerTransformer class. By sending specially crafted data, an attacker could exploit this vulnerability to execute arbitrary Java code on the system.
CVSS Base Score: 9.8
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/107918 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

The following Versions of WebSphere Application Server and IBM WebSphere Application Server Hypervisor Edition may be affected:

  • Version 8.5 and 8.5.5 Traditional and Liberty
  • Version 8.0
  • Version 7.0
Prior Versions of WebSphere Application Server are not affected.

Remediation/Fixes

For IBM WebSphere Application Server Liberty
For Liberty V8.5.5.0 through 8.5.5.9 and 16.0.0.2 through 17.0.0.3 using the optional EJB Embeddable Container and JPA Client Feature:

If you use Liberty and you have the following files on your system:

· com.ibm.ws.ejb.embeddableContainer_nls_8.5.0.jar

· com.ibm.ws.jpa.thinclient_8.5.0.jar

then you are using the vulnerable feature and you should upgrade these jars to the 17.0.0.4 version.

To upgrade the jars that were installed with archive install:

  • Apply the Liberty extras jar, wlp-extras-17.0.0.4.jar from the Liberty Fix Pack 17.0.0.4 or later.

To upgrade the jars that were installed with the IBM installation manager:

  • Delete the EJB Embeddable Container and JPA Client jars from the ${wlp.install.dir}/dev/tools/containers directory, and then use the wlp-extras-17.0.0.4.jar from the Liberty Fix Pack 17.0.0.4 or later to install the fixed version. More information can be found in the Knowledge Center .

--OR
  • Apply Liberty Fix pack 17.0.0.4 or later.

To upgrade the jars from WASdev:
Important notes: The version of WebSphere Liberty that you use and the version of the developer extra jar files do not need to match Fixpack levels. The Application Server does not contain the vulnerability but it is present in the jars that are part of the developer extras.



For V8.5.0.0 through 8.5.5.7 WebSphere Liberty:

The IBM WebSphere Application Server Liberty only enables the Apache Commons Collections if you are using ONE of the following three features:

  • jsf-2.0
  • jsf-2.2
  • jpa-2.0

You may be vulneraable if you are using any one of these features. To determine if you are vulnerable you can look in the console.log for this message:

[AUDIT ] CWWKF0012I: The server installed the following features: [xxxxx]

If in place of the xxxxx it does not contain any one of those three features listed then you are not vulnerable.

· If you are vulnerable then upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix PI52103

-- OR

· Apply Fix Pack 8 (8.5.5.8), or later.


For IBM WebSphere Application Server and IBM WebSphere Application Server Hypervisor Edition:

For V8.5.0.0 through 8.5.5.7:

-- OR
  • Apply Fix Pack 8 (8.5.5.8), or later.

For V8.0.0.0 through 8.0.0.11: -- OR
  • Apply Fix Pack 12 (8.0.0.12), or later.

For V7.0.0.0 through 7.0.0.39:
-- OR
  • Apply Fix Pack 41 (7.0.0.41), or later.

IBM recommends that you review your entire environment to identify vulnerable releases of the open-source Apache Commons Collections and take appropriate mitigation and remediation actions.

Get Notified about Future Security Bulletins

Important note

IBM strongly suggests that all System z customers be subscribed to the System z Security Portal to receive the latest critical System z security and integrity service. If you are not subscribed, see the instructions on the System z Security web site. Security and integrity APARs and associated fixes will be posted to this portal. IBM suggests reviewing the CVSS scores and applying all security or integrity fixes as soon as possible to minimize any potential risk.

References

Complete CVSS v3 Guide
On-line Calculator v3

Related information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

13 November 2015: original document published
17 November 2015: updated cve number and added fixes for Liberty Profile
18 November 2015: clarified if Liberty is vulnerable or not]
21 December 2017: Liberty developer extras need to upgrade

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Cross reference information
Segment Product Component Platform Version Edition
Application Servers WebSphere Application Server Hypervisor Edition
Application Servers IBM HTTP Server
Application Servers WebSphere Application Server Liberty Core

Document information

More support for: WebSphere Application Server
General

Software version: 7.0, 8.0, 8.5, 8.5.5

Operating system(s): AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS

Software edition: Base, Developer, Express, Liberty, Network Deployment

Reference #: 1970575

Modified date: 02 January 2018


Translate this page: