IBM Support

InfoSphere Information Governance Catalog: log files

Question & Answer


Question

Where are the log files for IBM InfoSphere Information Governance Catalog found?

Cause

The log file names changed because InfoSphere Information Governance Catalog replaces IBM InfoSphere Business Glossary and IBM InfoSphere Workbench.

Answer


To troubleshoot InfoSphere Information Server activities that fail to run or have errors

Run the InfoSphere Information Server Collector tool to collect logs and configuration data, which provides details about why activities fail to run or have errors. The InfoSphere Information Server Collector tool is available in the main menu. For details, see Running the ISALite tool to verify the installation and troubleshoot.

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To troubleshoot InfoSphere Information Governance Catalog problems

On the Services tier:

  • If running WebSphere Application Server Liberty Profile
      • Look in .../IBM/InformationServer/wlp/usr/servers/iis/logs/:
                  1. igc.log (with any .1, .2, ...)
                  2. igc-admin-services.log (with any .1, .2, ...)
                  3. omd-importer.log (with any .1, .2, ...)
                  4. messages.log   
                    •  // often helps with "unknown errors" in the user interface

      Look in .../IBM/InformationServer/wlp/usr/servers/iis/ for memory heap dumps and java core dumps
                       // often helps when out of memory and the server hangs
       
  • If running WebSphere Application Server Network Deployment
        • Look in .../IBM/WebSphere/AppServer/profiles/InfoSphere/logs/:
            1. igc.log (with any .1, .2, ...)
            2. igc-admin-services.log (with any .1, .2, ...)
            3. omd-importer.log (with any .1, .2, ...)
            4. server1/SystemErr.log (include all versions with timestamps in their names)
            5. server1/SystemOut.log (include all versions with timestamps in their names)  
              • // often helps with "unknown errors" in the user interface

          Look in .../IBM/WebSphere/AppServer/profiles/InfoSphere/ for memory heap dumps and java core dumps
                      // often helps when out of memory and the server hangs
  

On the Engine tier, everything under:

      - C:\IBM\InformationServer\Server\DSOMD\logs

      - C:\IBM\InformationServer\Server\DSOMD\xml

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To troubleshoot istool commands

Log files for istool commands for InfoSphere Information Governance Catalog are found on the Services tier:


For Microsoft Windows operating system environment

C:\Documents and Settings\<username>\istool_workspace\.metadata\.log
    where <username> is the name of the operating system account of the user who runs this command.


For UNIX or Linux operating system environment

<user_home>/<username>/istool_workspace/.metadata/.log
    where <user_home> is the root directory of all user accounts, and <username> is the name of the operating system account of the user who runs this command.

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To troubleshoot Blueprint Director and IBM InfoSphere Information Governance Catalog for Eclipse

Log location is the default location for all Eclipse application: <workspace>\.metadata\.log
 
Or, from the Eclipse Menu, click Window > Show View > General > Error log. You have an option to export the error log:
 


[{"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Information Governance Catalog","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.5.0.1;11.5;11.3.1.2;11.3.1.1;11.3.1.0;11.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21970037