IBM Support

Cognos report shows "This content cannot be displayed in a frame".

Troubleshooting


Problem

Certain Cognos reports show an error "This content cannot be displayed in a frame" in place of the report data after applying OpenPages patch 7.0.0.4.

Symptom

Cognos reports may be configured to output the result into a browser window that uses frames. After such reports have been rendered, a user may select different options in the main window which cause an immediate change in the secondary frame panel.

In some situations, the frame will display the message above, and provide a separate hyperlink that will open a separate pop-up window, and display the data in there, instead of updating the frame "in-place".

Cause

In OpenPages patch 7.0.0.4, an undocumented change removed the ability to use HTML "frames" in the Application. This had an immediate effect on any Cognos reports that used frames to retrieve data from the Application server.

The change was reversed in patch 7.0.0.4.1.

Resolving The Problem

Apply patch 7.0.0.4.1. This will restore the ability to use frames with the Application.

[{"Product":{"code":"SSFUEU","label":"IBM OpenPages with Watson"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21969765