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MustGather Docs -Troubleshooting Guide for VM Manager Tool Connectivity Problem(s).

Question & Answer


Question

MustGather Docs -Troubleshooting Guide for VM Manager Tool Connectivity Problem(s).

Cause

Installing the VM Manager Tool via "Install VM Manager Tool" task from IBM License Reporting (ILMT) v9 site can be very easy. However configuring and getting it up running properly can be a bit challenging.

By default, at least one VM Manager Tool must be installed on the BigFix Server. Additional VM Manager Tool can also be installed via "Install Additional VM Manager Tool (OPTIONAL)" task if needed.

The default installation path for VM Manager Tool:

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN

Unix:
/var/opt/BESClient/LMT/VMMAN

Afterward, create a new VM Manager configuration for each virtual host server (vCenter, VMWare, Hyper-V, etc). Ensure to use the Test Connection button to check connectivity from BigFix Server to virtual host server.

After a Test Connection button is pressed, a new action "VM Manager Tool - connection test to....." is created from the BigFix Console showing the BigFix Server as a target and ensure it is completed with 100%.



Also ensure the following actions are submitted to run on a regular interval without expiration date. First one is the HW scan action running on all computers. Second one is to upload the VM Manager scan results back to BigFix server every 30 mins interval without expiration date. The data from these two actions is very important for PVU Subcapacity calculation in the ILMT tool.



Use the following steps below to gather information for the IBM Support Team to further diagnose the VM Manager Tool issue(s). Ensure to include or attach all the required docs in a PMR.

Answer


*** On the BigFix Server and perform the steps below with system admin rights (ie, root or Administrator credential)

1) Stop the VMMAN service

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN\vmman.bat -stop

Unix:
/var/opt/BESClient/LMT/VMMAN/vmman.sh -stop

2) Edit the following properties file with DEBUG mode:

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN\config\log4j.properties

Unix:
/var/opt/BESClient/LMT/VMMAN/config/log4j.properties

Change the following line from INFO to DEBUG

log4j.rootLogger=INFO, mylogger
to
log4j.rootLogger=DEBUG, mylogger

3) Optional: enable additional debugging information using the following settings:

A) To troubleshoot SSL handshake error, edit the vmman.bat or vmman.sh to enable DEBUG mode. Important to backup this vmman.bat or vmman.sh file prior making changes. If this step does not apply, proceed step 4 below.

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN\vmman.bat

Unix:
/var/opt/BESClient/LMT/VMMAN/vmman.sh

Add the following parameter "-Djavax.net.debug=ssl,handshake" to the statement under the "PROPERTIES DEFINITIONS" section (ensure there is a empty space before -Djavax.........):

Windows:
@REM ####### PROPERTIES DEFINITONS #######
SET VMM_PROPERTIES_DEFS=-Dcom.ibm.license.mgmt.datacollector.home.path="%VMM_HOME%"

to
@REM ####### PROPERTIES DEFINITONS #######
SET VMM_PROPERTIES_DEFS=-Dcom.ibm.license.mgmt.datacollector.home.path="%VMM_HOME%" -Djavax.net.debug=ssl,handshake

Unix:
####### PROPERTIES DEFINITONS #######
VMM_PROPERTIES_DEFS=-Dcom.ibm.license.mgmt.datacollector.home.path="$VMM_HOME"


to

####### PROPERTIES DEFINITONS #######
VMM_PROPERTIES_DEFS=-Dcom.ibm.license.mgmt.datacollector.home.path="$VMM_HOME" -Djavax.net.debug=ssl,handshake

B) For all others, use the following parameter "-Djavax.net.debug=all" instead.

4) Start up the VMMAN service

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN\vmman.bat -run

Unix:
/var/opt/BESClient/LMT/VMMAN/vmman.sh -run

Note: if SSL handshake debug mode is enabled as per step 3 above, there will be standard debug outputs displayed from the vmman.bat or vmman.sh command. Then run the following command instead to capture the outputs to a file. On Windows, ensure C:\temp folder is existed or it can be redirected to any other folders by changing the path.

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN\vmman.bat -run > C:\temp\vmman.out

Unix:
/var/opt/BESClient/LMT/VMMAN/vmman.sh -run > /tmp/vmman.out

5) Now recreate the problem

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN\vmman.bat -testconnection > C:\temp\testconnection.out

C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN\vmman.bat -status > C:\temp\status.out

Unix:
/var/opt/BESClient/LMT/VMMAN/vmman.sh -testconnection > /tmp/testconnection.out

/var/opt/BESClient/LMT/VMMAN/vmman.sh -status > /tmp/status.out


6) Finally, run -retrievedebugdata parameter to capture the debug information into a debugData.zip file created in the current directory.

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN>vmman.bat -retrievedebugdata

Unix:
/var/opt/BESClient/LMT/VMMAN/vmman.sh -retrievedebugdata

7) Send back the following files to PMR for review:

vmman.out
testconnection.out
status.out
debugData.zip

8) It is also recommended to zip or tar up this folder as well in case there is a need for the IBM Support Team to review additional information.

Windows:
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\VMMAN

Unix:
/var/opt/BESClient/LMT/VMMAN/

If the above files are very large in size, upload them using link below.
Upload to IBM support

==================================================

Depending on what the VM Manager Tool issue is, it is also recommended to send additional docs as described below.

1) No VM Manager Data status.



Provide the following items:

- Go to Reports | Hardware Inventory | click on CSV button to export the information to CSV file. Send back CSV file.




- Go to Management | VM Managers | screen shot of this page.

- Go to Management | Data Imports | screen shot of this page showing the latest import tasks and status


2) For other statuses, the information gathered from the above 8 steps should be a good starting point. There might be additional steps or information are required later on if needed.

[{"Product":{"code":"SS8JFY","label":"IBM License Metric Tool"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.0;9.0.1;9.1;9.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
26 April 2021

UID

swg21968438