IBM Support

RTC (Rational Team Client) P2 plugin on RAD 9.0 does not shell share on Linux

Troubleshooting


Problem

After installing Rational Application Developer (RAD) 9.0 with a correct RAD 9.0 licence and then installing a compatible RTC plugin (p2 Connector) it did bring up the Work Item perspective. However, when sharing/starting the workspace with RAD 9.0 , it says the project cannot been found in RAD because source control cannot be found.

Symptom

RTC plugin functionality not available in RAD

Cause

RAD had been installed as root. RAD was not started as root when installing the RTC P2 Plugin

Environment

Open Client Red Hat Linux 6.5

Diagnosing The Problem

Check permissions/Id with which RAD was installed in Linux.

This is also similar to Windows 7, in which it is necessary to start RAD using "Run As Administrator" if it is install in C:/Program Files... , even if you are an Admininstrator Id. This is is especially critical if installing a plugin using the Eclipse install RAD : Help > Install New Software...

Resolving The Problem

Running run RAD as "root" to install the RTC plugin resolved the problem.

Changing permissions on the RAD install directory for the other user id would have also helped. Once you are root, do: chown -R user:group , to the path for your RAD/eclipse installation. Then your regular user should be able to install plugins. Also it is not necessary to install RAD/eclipse as the root user. Root can still use RAD/eclipse when another user installs it and owns it.

[{"Product":{"code":"SSRTLW","label":"Rational Application Developer for WebSphere Software"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8.5.5;8.5.5.1;8.5.5.2;9.0;9.0.1;9.0.1.1;9.1;9.1.0.1;9.1.1;9.0.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21967339