IBM Support

IBM Workload Scheduler upgrade support extended to include the upgrade from version 8.5.1 to 9.3.

Question & Answer


Question

IBM Workload Scheduler upgrade support has been extended to include the upgrade from version 8.5.1 to 9.3. This Technote contains: - Link to the package containing the prerequisite iFixes and related readme files. - Upgrade procedures

Cause

Before starting to upgrade the product, verify that your network has the minimum required supported versions of the operating system, product, and database, as described in IBM Workload Scheduler: Planning and Installation, Before upgrading.

From IBM Fix Central, at link:
https://www-947.ibm.com/support/entry/myportal/search_results?sn=spe&filter=keywords%3Aibmsupportfixcentralsearch&q=9.3.0-TIV-TWS-UPGRADE-FP0000
download the 9.3.0-TIV-TWS-UPGRADE-FP0000 package.

The package contains the following prerequisite iFixes and related readme files:

- iFix for Dynamic Workload Console upgrade from version 8.5.1 to 9.3
- iFix for database upgrade from version 8.5.1 to 9.3
- iFix for agent direct upgrade from version 8.5.1 to 9.3

Instructions are provided in the attached .pdf file on how to upgrade IBM Workload Scheduler components from version 8.5.1 to 9.3. (See the Answer section below).

Compatibility
-Master domain manager version 9.3 supports both dynamic agents and fault-tolerant agents
version 8.5.1.
-Master domain manager version 8.5.1 supports fault-tolerant agents version 9.3, but not dynamic
agents version 9.3.

Limitations
-For the master domain manager the direct upgrade is not supported. Only parallel upgrade from
version 8.5.1 to 9.3 is supported.


[{"Product":{"code":"SSGSPN","label":"IBM Workload Scheduler"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.5.1;9.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21966921