IBM Support

Loading Applications screen takes a long time in TM1 Applications

Troubleshooting


Problem

When trying to open TM1 Applications - http://:/pmpsvc the bar "Loading Applications" appears for a long time. The applications are slow to load.

Symptom

The "loading Applications" bar appears for a long time. Error in TM1web.log: ERROR () com.cognos.pmta.api.modelmanagement.ModelManager - Failed to open application '<server><TM1server>' as '<server><TM1server>' com.ibm.cognos.tm1.TM1Exception: SystemServerNotFound"

Cause

The system is trying to connect to all the tm1 servers in the "Administer IBM Cognos TM1 Applications" page (stored in fmpsvc_config.xml)

Environment

TM1 10.2.2

Diagnosing The Problem

Verify the tm1web.log for error: ERROR () com.cognos.pmta.api.modelmanagement.ModelManager - Failed to open application '<server><TM1server>' as '<server><TM1server>' com.ibm.cognos.tm1.TM1Exception: SystemServerNotFound"

Resolving The Problem

Remove any TM1 servers that are inactive/you do not wish to connect to from the "Administer IBM Cognos TM1 Applications"

1) Access this page by clicking on the tools icon at the top right of the TM1 Applications screen

2) Select the checkbox for any inactive servers you no longer wish to connect to.

3) Click remove

4) Click OK

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21966840