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Restore DB process fails with ANR2971E

Troubleshooting


Problem

The restore DB process fails with message: ANR2971E Database backup/restore/rollforward terminated - DB2 sqlcode -1036

Symptom

During a restore DB process of the Tivoli Storage Manager server, the following error may be issued:

ANR2971E Database backup/restore/rollforward terminated - DB2 sqlcode -1036

As a result, the operation fails and Tivoli Storage Manager is not restored.

Cause

The error is most likely caused by :

- lack of permission rights on some folders of the DB structure
- missing particular folders for DB2

Usually this kind of error can be seen if the procedure of moving a DB container has been applied, but the command "dsmserv removedb TSMDB1" did not completely clean up the system.

Diagnosing The Problem

Except for the error in the restore DB processing output :

ANR2971E Database backup/restore/rollforward terminated - DB2 sqlcode -1036

The following error is present in the db2diag.log :



2015-08-19-11.18.42.790024+120 I63467212A674 LEVEL: Severe
PID : 32571610 TID : 1544 PROC : db2sysc 0
INSTANCE: tsmtest NODE : 000
APPHDL : 0-13 APPID: *LOCAL.tsmtest.150819091842
AUTHID : TSMTEST
EDUID : 1544 EDUNAME: db2agent (instance) 0
FUNCTION: DB2 UDB, data protection services, sqlpgOpenLFH, probe:750
MESSAGE : ZRC=0x860F000A=-2045837302=SQLO_FNEX "File not found."
DIA8411C A file "" could not be found.
DATA #1 : <preformatted>
There was an error opening log control files:
/home/tsmtest/tsmtest/NODE0000/SQL00001/SQLOGCTL.LFH.1
/home/tsmtest/tsmtest/NODE0000/SQL00001/SQLOGCTL.LFH.2

Resolving The Problem

A possible solution is to run :

1) db2 drop db TSMDB1

** If this fails with an error then move onto step 3)

2) Run the restore DB command again

** If this completes successfully, the remaining steps can be ignored

3) Assuming step 1) had an error similar to the above db2diag.log extract, then change directory to :

/home/tsmtest/tsmtest/NODE0000/ (as in the above example)

Rename the directory SQL00001 to SQL00001.bak

4) Issue "db2diag -A" to generate a new db2diag log file

5) Run the restore DB command again

Related Information

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21966255