Troubleshooting
Problem
Unable to start a Cognos application via Cognos configuration. CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos service in the time allotted.
Symptom
[Start Service]
[ ERROR ] CFG-ERR-0106 IBM Cognos Configuration did not receive a
response from the IBM Cognos service in the time allotted.
Check that IBM Cognos service is available and properly configured.
Cause
A wrong version of Java was being used and there was not enough memory for the application server
Environment
Windows 2008 with a 64 bit install of Cognos
Diagnosing The Problem
In Cognos Configuration press ctrl-F3 . Take note of Java Install path. On windows this should point to c10Install/ bin64/jre....
Resolving The Problem
Steps to Unset the JAVA_HOME variable
1. Unset the java home system variable. If you need Java for another vendor or tool you can set the Java variable for the user
2. Set the Cognos service to manual so it does not start automatically at start up.
3. Restart the server - after start up press ctrl + f3 your java install path should point to c10install/bin/jre...
4. Recreate the cryptographic keys according to this document http://www-01.ibm.com/support/docview.wss?uid=swg21694322 for your 10.2.2. environment and this
5. Start Cognos
6. If it successful you can set the service back to automatic.
If you are still not able to start Cognos.
1. Increase the memory for the IBM Cognos service
Default for 10.2.2 is WebSphere Liberty and set to 1024 increase this to 2048
2. As a test change the application server from WebSphere Liberty to tomcat and try it out.
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Document Information
Modified date:
15 June 2018
UID
swg21965068