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IBM Spectrum Protect BACKUP DB can fail with ANR2968E sqlcode -2033 sqlerrmc 75

Troubleshooting


Problem

IBM Spectrum Protect (formerly Tivoli Storage Manager) server database backup failure with ANR2968E sqlcode -2033 and sqlerrmc 75 if TCPPORT not configured correctly.

Symptom

The following behavior recorded in the activity log after initiating a IBM Spectrum Protect server database backup:


08/15/2015 01:09:14 ANR4626I Database backup will use 1 streams for processing  with the number originally requested 1. (SESSION: 1246, PROCESS: 44)
08/15/2015 01:09:26 ANR0406I Session 1516 started for node $$_TSMDBMGR_$$ (DB2/LINUXX8664) (Tcp/Ip localhost(36293)). (SESSION: 1516)
08/15/2015 01:09:27 ANR0475W Session 1516 for node $$_TSMDBMGR_$$ (DB2/LINUXX8664) refused - node is not allowed to initiate sessions on administrative port. (SESSION: 1516)
08/15/2015 01:09:27 ANR0403I Session 1516 ended for node $$_TSMDBMGR_$$ (DB2/LINUXX8664). (SESSION: 1516)
08/15/2015 01:09:28 ANR0406I Session 1518 started for node $$_TSMDBMGR_$$ (DB2/LINUXX8664) (Tcp/Ip localhost(36294)). (SESSION:   1518)
08/15/2015 01:09:29 ANR0475W Session 1518 for node $$_TSMDBMGR_$$ (DB2/LINUXX8664) refused - node is not allowed to initiate sessions on administrative port. (SESSION: 1518)
08/15/2015 01:09:29 ANR0403I Session 1518 ended for node $$_TSMDBMGR_$$ (DB2/LINUXX8664). (SESSION: 1518)
08/15/2015 01:09:29 ANR2968E Database backup terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: 75 . (SESSION: 1246, PROCESS: 44)
08/15/2015 01:09:31 ANR0985I Process 44 for Database Backup running in the BACKGROUND completed with completion state FAILURE at 01:09:31 AM. (SESSION: 1246, PROCESS: 44)
08/15/2015 01:09:31 ANR1893E Process 44 for Database Backup completed with a completion state of FAILURE. (SESSION: 1246, PROCESS: 44)

Cause

This condition is triggered when the database backup configuration is pointing to the servers TCPADMINPORT, instead of the TCPPORT. The API used by the database backup must point to the servers TCPPORT, not the TCPADMINPORT.

Resolving The Problem

By default, the TCPPORT option defines the port in which client and administrative sessions connect to the server. A user can change the port in which administrative sessions connect using the TCPADMINPORT option to split client and administrative sessions onto unique ports.

It is important to note that the IBM Spectrum Protect server database backup configuration must continue to point to the TCPPORT, and not the TCPADMINPORT. If the database backup configuration points to the TCPADMINPORT, the ANNR2968E with sqlcode -3022 and sqlerrmc 75 will occur, and any attempts to run BACKUP DB will fail.

There are two options available to prevent these errors:

1. Change the IBM Spectrum Protect Server's TCPPORT option so that it matches the database backup configuration (API):

IMPORTANT: Using this method will change the port in which client sessions must connect to the server. If the existing clients are not already configured to use this port, and you make a change using this method, you will see client backup failures until those clients are reconfigured to use the new port! Use extreme caution when using this method as it may have significant operational impact.

  • Review the TCPPORT defined in the dsm.sys used by the database backup. This file can be located by logging in as the instance owner and viewing the "DSMI_DIR" environment variable. By default, the location on V6 is "/opt/tivoli/tsm/client/api/bin64/" and on V7 the location is "/opt/tivoli/tsm/server/bin/dbbkapi/".
  • Change the TCPPORT in the dsmserv.opt used by the server to match the TCPPORT defined in the dsm.sys located above.
  • Recycle the Tivoli Storage Manager server so that the new TCPPORT is accepted.

2. Change the IBM Spectrum Protect API's TCPPORT option so that it matches the server's configuration:
  • Review the TCPPORT defined in the dsmserv.opt used by the server. This file is located in the instance user's home directory (by default).
  • Change the TCPPORT defined in the dsm.sys used by the database backup configuration to match the TCPPORT defined in the dsmserv.opt located above. Note that the correct dsm.sys can be located by logging in as the instance owner and viewing the "DSMI_DIR" environment variable. By default, the dsm.sy location on V6 is "/opt/tivoli/tsm/client/api/bin64/" and on V7 the location is "/opt/tivoli/tsm/server/bin/dbbkapi/".
  • A recycle of the IBM Spectrum Protect server is not required.

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Product Synonym

ITSM ADSM TSM IBM Spectrum Protect

Document Information

Modified date:
01 February 2022

UID

swg21964585