IBM Support

Verifying Production Status on a Cognos Server-License

Troubleshooting


Problem

Trying to migrate from Cognos BI 10.2.2 Non-Production to Production. After migration to Production, how to confirm the switch.

Symptom

Steps to switch from Non-Production to Production version in Cognos 10.2.2 , verifying the switch and the current installation version.

Cause

Switch from already installed Cognos BI 10.2.2 Non-Production environment.

Environment

Cognos 10.2.2 Production and Non-Production Environment

Diagnosing The Problem

There are two factors that determine the switch from one version to the other (Production/Non-Production). One factor is the presence of the file gs.nonproduction.properties or gs.production.properties in the bin directory of the cognos installation. This file will switch accordingly to the production or non-production state of Cognos. This is specific to Cognos 10.2.2.

The other factor is the cmplst file, wherein the line SWTAGNP_BI_SERVER_name and SWTAG_BI_SERVER_name would be updated, with NP to indicate the Non-Production, and the omission of NP to confirm Production release. There might be scenario where the properties file in bin directory might not get updated, during the switch, but the change in the mentioned line in cmplst would still validate the switch of versions.

Steps to see behavior:

Initial Configuration:
Cognos 10.2.2 Non-Productions Installation:
1.) In the Cognos Installation Directory, navigate to Bin folder.
2.) The file "gs.nonproduction.properties " confirms the existing Non-Production installation.
3.) Check the current cmplst.txt configuration file and it if it includes the line: “SWTAGNP_BI_SERVER_name=SWTAG BI Server - Non-Production”
confirms the existing Non-Production Installation.

Re-installed the Cognos 10.2.2 BI Production Release (Steps are Below):
1.) Run the Cognos BI Server 10.2.2 setup file.
2.) When prompted for the Installation Directory, select the same directory as the Non-Production 10.2.2 Installation.
3.) Also select the same Folder Name in Program Files Directory Structure.
4.) Select "Production" radio button in the Server Use Type Section.
5.) Complete Installation by pressing Finish.

Verifying the switch to Cognos 10.2.2 Production Install
1.) In the Cognos Installation Directory, navigate to Bin folder.
2.) The presence of file "gs.production.properties " confirms the switch to Production installation.
3.) Check the modified cmplst.txt configuration file and if it includes the line: “SWTAG_BI_SERVER_name=SWTAG BI Server” confirms the switch to Production Installation.

Resolving The Problem

1.) In the Cognos Installation Directory, navigate to Bin folder.
2.) Firstly, search for the file "gs.nonproduction.properties " or "gs.production.properties ", each of these files confirm the corresponding environments (Production or Non-Production).
3.) Secondly check the the cmplst file:
If it says “SWTAGNP_BI_SERVER_name=SWTAG BI Server - Non-Production”
Then its a Non Production Installation and the Product has not been switched to Production.

If it says: cmplst and it says: “SWTAG_BI_SERVER_name=SWTAG BI Server”
It confirms the Production Installation.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Administration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21964429