IBM Support

Cron Task Does Not Run After System Restart

Question & Answer


Question

Is there a configuration to force Cron Tasks to resume schedule after a system restart?

Cause

It is possible that, due to System Properties configuration, Cron Tasks will not automatically resume their run schedule after a system restart.

Answer

The value of the global system property, mxe.crontask.donotrun, should be null to allow all Cron Tasks to run. Some clients have encountered the unexpected setting of this property to 'ALL'. This means that no Cron Task will run without performing an initial, manual startup of each Cron Task upon system restart.

-Go To System Configuration | Platform Configuration | System Properties
-In the Global Properties section click Filter
-In the Property Name field enter "mxe.crontask" and press Enter
-Highlight the row for mxe.crontask.donotrun
-In the Global Value field remove the value, "ALL" (update the value to be null)
-Save the record
-Click the checkbox in the Global Properties section to select the mxe.crontask.donotrun property
-Select Action | Live Refresh, then click OK

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cron Task Setup","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"Enterprise","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21964244