IBM Support

Preserving Fastback for Workstations CAC settings

Question & Answer


Question

When the situation occurs that the Central Administration Console (CAC) must be removed and reinstalled or it needs to be moved to a new system, how can the current settings and configuration be migrated to the new install?

Cause

The Fastback for Workstations Administration guide does not clearly outline how to preserve data during upgrade, migration or reinstall.

Answer

When the need arises to remove or move the current installation of the CAC you can preserve the setting of the current configuration by keeping a copy of specific files.

First begin by stopping the Fastback for Workstations CAC service in the Windows services.

The default install directory of the CAC is:


C:\Program Files\Tivoli\TSM\CAC\

Under this location locate the fbfw directory. Default location:
C:\Program Files\Tivoli\TSM\CAC\wlp\usr\servers\FBFWCAServer\fbfw

Create a copy of this directory and preserve it in a safe location.

After the new install of the CAC is finished, confirm that the service is started and that you are able to log into the CAC successfully. Once this is confirmed, close the browser window and then stop the CAC service. In the fbfw folder that was previously saved, locate the CA_DB folder. Copy this folder into the new fbfw folder. If custom scripts were created also copy the scripts.dat file into the fbfw folder.

Once this has been copied into the current fbfw directory, start the CAC service again and log back into the portal. Browse the GUI to ensure that the original configuration has returned.

Related Information

[{"Product":{"code":"SS6PEB","label":"Tivoli Storage Manager FastBack for Workstations"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2019

UID

swg21964137