Troubleshooting
Problem
After having properly configured the XenServer agent, the agent fails anyway to start so nothing is showed in TEP.
Symptom
The file KXI_<instance>_output.log shows error message:
[KXI] KXI5101I Required Java library not found. Please confirm that the xenserver-6.0.0-1.jar has been placed in the agent bin directory.
Cause
An important jar file is actually missing from the agent binary folder.
Diagnosing The Problem
File xenserver-6.0.0-1.jar is required, as also specified in the Agent User's guide.
The manual also say how to download the SDK package that contains the necessary jar file:http://xenserver.org/partners/developing-products-for-xenserver.html
Anyway, XenServer SDK 6.0.0.1 is no longer available because that version of the product is out of support.
Basing on what we know from XenServer team, the 6.2 SDK is backward compatible and can be used in place of the older versions.
Resolving The Problem
Even if XenServer SDK 6.0.0.1 is no longer available from the xenserver portal, you can proceed as follow:
1) Download the 6.2.0 version of the SDK from this URL:
http://downloadns.citrix.com.edgesuite.net/7289/XenServer-6.2.0-SDK.zip
2) Extract the following files:
- xenserver-6.2.0-1.jar
- ws-commons-util-1.0.2.jar
3) Copy those files into the agent binary folder:
- Windows: %CANDLE_HOME%\TMAITM6
- Windows 64: %CANDLE_HOME%\TMAITM6_x64
- Linux: $CANDLEHOME/platform_code/xi/bin
4) Rename the file xenserver-6.2.0-1.jar in xenserver-6.0.0-1.jar
Especially on Linux, be sure the files have the same permission bits and owner/group of the other agent binary files.
5) Restart the agent and verify that error message KXI5101I disappeared from KXI_<instance>_output.log.
Then check TEP client to see the new agent workspaces.
Product Synonym
IBM Tivoli Monitoring for Virtual Environments: Citrix XenServer agent
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Document Information
Modified date:
17 June 2018
UID
swg21963557