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** Troubleshooting ** Intermittent "The ConnectionString property has not been initialized" errors

Troubleshooting


Problem

User performs actions inside Controller. From time to time (occasionally / intermittently) the user receives an error message. The exact error message will vary (depending on what the end user is doing), but it will include the phrase "The ConnectionString property has not been initialized".

Symptom

Example error:

Standard Error

Error Details


Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.ArgumentException: The ConnectionString property has not been initialized.
at Microsoft.VisualBasic.ErrObject.Raise(Int32 Number, Object Source, Object Description, Object HelpFile, Object HelpContext)
at ControllerServerCommon.RaiseErrSrv.RaiseError(String sUser, Int32 lErrNo, String sErrSource, String sErrDesc, String sErrHelpFile, Int32 lErrHelpContext)
at FrAccountS.AccountSet.ISet_SelectAll(String sGuid, String sSelectCriterion, String sUser, Int32 lLLocale)
at Cognos.Controller.Proxy.CCRWS.AccountSet_SelectAll(String sGuid, String sSelectCriterion, String sUser, Int32 lLLocale)

Cause

There are several possible causes:

  • Scenario #1 (common) - Defect (reference APAR PI32861) in Controller 10.2.0.
    • TIP: See separate IBM Technote #1683841 for more details.
  • Scenario #2 (rare) - CGI timeout occurring on 'gateway' server
    • NOTE: This only affects customer who use the (rare) "t=controller" configuration (where they have a dedicated gateway server, acting as a proxy/relay-server).
  • Scenario #3 (common) - Defect (reference APAR PI54534) in Controller 10.2.1.
    • TIP: See separate IBM Technote #1973433 for more details.
  • Scenario #4 (common) - Limitation of the Controller architecture, triggered by the default settings for the IIS application pool recycle
    • TIP: See separate IBM Technote #2016839 for more details.
  • Scenario #5 (rare) - Constant (non-intermittent) error caused by using third-party 'Appsense' tool
    • TIP: See separate IBM Technote #0731143 for more details.
  • Scenario #6 - Limitation of some environments (Citrix / Terminal Services / Cloud) triggered by the end user re-connecting to an old 'disconnected' session (which was still running on the Citrix server), that has timed out of its CA/IIS authentication.
    • TIP: See separate IBM Technote #0880855 for more details.

Environment

Scenario #2 - Customer has their client device configured to use the 't=controller' parameter.

  • For more details, see separate IBM Technote #1367311.

Resolving The Problem

Scenario #1 - Defect in Controller 10.2.0

Fix
Upgrade to Controller 10.2.1 (10.2.5100) or later.

Workaround
Increase the application pool timeout value.

  • TIP: See separate IBM Technote #1683841 for more details.

Scenario #2 - CGI timeout occurring on 'gateway' server

Increase the value for 'Time-out' for the CGI system on the gateway server.

Steps:

  • The following steps are based on Windows 2008. The steps may vary slightly for different operating systems.

    1. Obtain a short period of 'downtime' for Controller

    2. Logon to the 'Gateway' server, as a Windows administrator

    3. Right-click on "Computer" and choose "manage" (to launch 'Server Manager')

    4. Expand "Roles - Web Server (IIS)" and click "Internet Information Services (IIS) Manager"


    5. In the right-hand window, expand your webserver's name, and expand "Sites" and then select "Default Web Site"
    6. In "Features View", double-click "CGI".
    7. Under 'Behavior', increase the time-out value in the 'Time-out (hh:mm:ss)' property.
  • This needs to be longer than the longest operation that you perform in Controller (for example a database optimisation). For example to "02:00:00" = 2 hours
  • For example, increase it to "10:00:00" = 10 hours to be sure!



TIP: If your database optimisation takes longer, then increase this further.

9. Click 'Apply' (in the 'Actions' pane)
10. Launch a command prompt (Start - Run - 'CMD' <Enter>)
11. IISRESET <Enter>
12. Launch Controller, and test.

Scenario #3 - Defect in Controller 10.2.1

See separate IBM Technote #1973433 for details.

Scenario #4 - Limitation of Controller (all versions)

Modify the relevant IIS application pool recycle settings.

  • See separate IBM Technote #2016839 for details.

  

Scenario #5 - Caused by third-party 'AppSense' tool

Reconfigure AppSense to not include the file 'ccr.config' (located inside "%APPDATA%\Cognos\ccr") to be excluded.

  • See separate IBM Technote #0731143 for details.
   

Scenario #6 - The end user has re-connected to an old 'disconnected' session (which was still running on the Citrix server)

Make sure that you logoff from Controller/Excel cleanly, when you have finished using the software (for example at the end of the working day).
  • In other words, do not simply leave the cloud Excel session 'disconnected' (running in Cloud but not visible on the end user's PC).
  • See separate IBM Technote #0880855 for details.

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Document Information

Modified date:
12 April 2019

UID

swg21963432