IBM Support

Missing Scan Results in SUA/LMT Home page, however everything checks out

Question & Answer


Question

Scans are running, uploading to IEM servers sha1 folder, and dbo.uploads and dbo.uploads_availability is also updated in bfent IEM database, yet, the import logs at debug level do NOT show that the citsearch files are being imported for some reason.

Cause

As per L3
It seems that the citsearch software scan output file was not processed correctly in the
past and now it is not being processed any more since SUA/LMT caching mechanism.

Answer

1) Log on to the CIT endpoint
2) Go to LMT\CIT directory
3) Unpack <computer_id>_cit.xml.bz2
bzip -d <computer_id>_cit.xml.bz2
4) Edit unpacked
<computer_id>_cit.xml
and add an empty line at the end of file. The xml content of the file
should be the same but hash and size will change.

After a moment the "Upload Software Scan Results" task should detect new
scan file, bzip the <computer_id>_cit.xml file and upload it to the IEM
server.

Then you can import data in SUA/LMT. After the import, check
if the "Missing Scan Result" for <computer_id> should go away.

[{"Product":{"code":"SS8JFY","label":"IBM License Metric Tool"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

12050;379;000

Document Information

Modified date:
26 April 2021

UID

swg21963282