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"SQL2071N An error occurred while accessing the shared library "C:\PROGRA~1\IBM\SQLLIB\bin\db2tsm.dll"" trying to connect to database

Troubleshooting


Problem

Customer has restored copy of a DB2 database (from a backup) onto a new DB2 server. User has created a new database connection (to point to this new database copy). Afterwards, user launches 'Controller Configuration', opens 'Database Connections' and selects a database. User clicks green 'tick' to test the connection. An error appears.

Symptom

Error using Database Conversion:

Connection failed


SQL2071N An error occurred while accessing the shared library "C:\PROGRA~1\IBM\SQLLIB\bin\db2tsm.dll". Reason code: "1".

Cause

Backup was performed from a source DB2 server which uses Tivoli Storage Manager to archive its logs.

Diagnosing The Problem

Run the following command to find out the current state of the database:



    db2 get db cfg for ccr

TIP: Replace 'ccr' with the name of your database.

You will get a response similar to:




This is saying that the database requires to be rolled forward.

Therefore, run this command:
    db2 rollforward db ccr complete

You will get the following message:

SQL2071N An error occurred while accessing the shared library
"C:\PROGRA~1\IBM\SQLLIB\bin\db2tsm.dll". Reason code: "1".

This confirms that those TSM logs are the culprit.

Resolving The Problem

Update the database to use 'DISK' (rather than TSM) logs.

Steps:

Run the following command:

    db2 update db cfg for <DBNAME> using LOGARCHMETH1 DISK:<Disk Path>

For example:

    db2 update db cfg for CCR using LOGARCHMETH1 DISK:D:

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21962363