Troubleshooting
Problem
Server upgrade can fail due to a problem with the db2icrt command.
Symptom
The .xml log file created during upgrade may contain errors similar to the following:
NOTE: The .xml file can be found using technical document listed below.
Collecting Data for Tivoli Storage Manager: V7 Server Install or upgrade
ERROR: com.tivoli.dsm.server.db2.DB2Info.recreateInstance(1368) : Failed to create instance
In directory /var/ibm/InstallationManager/logs/native there are log files for each step. One of these logs will show the following error when trying to run db2icrt
Command: /opt/tivoli/tsm/db2/instance/db2icrt -u xxx xxx
The host name "yourhostname" is invalid. Specify a valid host name.
- A major error occurred during the execution that caused this program to
terminate prematurely. If the problem persists, contact your technical service representative.
DBI1264E This program failed. Errors encountered during execution were written to the installation log file. Program name: db2icrt. Log file name: /tmp/db2icrt.log.12345678.
The /tmp/db2icrt.log.XXX file may contain additional errors similar to the following:
ERROR: The host name "yourhostname" is invalid. Specify a valid host name.
ERROR: The "db2icrt" command failed. Ensure the command parameters are valid, that errors reported in the log file are fixed, then rerun the command.
Cause
The /etc/hosts file may contain multiple entries with unique IP addresses for the same hostname
Diagnosing The Problem
Review the etc/hosts file to confirm whether multiple references exist for the hostname, as seen in the following example:
127.0.0.1 loopback localhost
10.09.08.07 yourhostname
10.06.05.04 yourhostname
10.03.02.01 yourhostname
Resolving The Problem
There should only be a single entry (no more than one) in the /etc/hosts file for this host. The entry should have a valid IP address attached to it. For example, the /etc/hosts file should look like the following with one reference:
127.0.0.1 loopback localhost
10.09.08.07 yourhostname
After the /etc/hosts file has been edited appropriately, perform the following actions to manually recreate the DB2 instance:
1) While logged in as the root user, issue the following command to recreate the DB2 instance (where <instance> is the name of the DB2 instance):
# /opt/tivoli/tsm/db2/instance/db2icrt -u <instance> <instance>
2) While logged in as the DB2 instance owner, issue the following command to update DB2 to reflect the correct database path (where <dbpath> is the default database directory):
$ db2 update dbm cfg using dftdbpath <dbpath>
3) Issue the following to upgrade the DB2 database (if necessary):
$ db2 upgrade database tsmdb1
4) Issue the following commands to ensure that DB2 can be successfully started/stopped:
$ db2stop
$ db2start
5) Restart the Tivoli Storage Manager server normally
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21961937