Troubleshooting
Problem
A BACKUP VM operation with -mode=IFINCREMENTAL fails with ANS9351E and ANS1314E errors.
Symptom
The following command is used for the backup :
dsmc backup vm -vmfulltype=vstor -vmbackuptype=fullvm -asnodename=VMNODENAME -domain.vmfull="VM=vm.data.com" -mode=IFINCREMENTAL
The command fails with the following errors :
Full BACKUP VM of virtual machines specified in DOMAIN.VMFULL option.
Backup VM command started.
Total number of virtual machines to process: 1
Accessing as node: VMNODENAME
Starting Full VM backup of VMware Virtual Machine 'vm1.data.com'
mode: 'Incremental Forever - Incremental'
target node name: 'NODENAME'
data mover node name: 'DATA1'
application protection type: 'VMware'
application(s) protected: 'n/a'
Creating snapshot for virtual machine 'VM1'
...
17,803 VM Configuration [Sent]
ANS9351E Data was not available on server and was skipped.
ANS4174E Full VM backup of VMware Virtual Machine 'VM1' failed with RC=14 mode=Incremental Forever - Incremental, target node name='NODENAME', data mover node name='DATA1'
ANS1228E Sending of object 'vm.data.com' failed
ANS1314E File data currently unavailable on server
Cause
VMware control file required for the VM incremental backup is damaged or unavailable on the server.
Diagnosing The Problem
During the incremental backup of a VM guest, the VMware control file stored on the Tivoli Storage Manager server needs to be retrieved. If for any reason the control file is not available on the server, the errors are logged.
Resolving The Problem
When the VMware control file is not available on the server, run a FULL VM backup to recreate the control file. In this example, instead of using "-mode=IFINCREMENTAL", run a backup with "-mode=IFFULL". The IFFULL backup will recreate the control file so that future IFINCREMENTAL backups can succeed.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21961789