Question & Answer
Question
Why Can I not find IBM TRIRIGA CleanupAgent after upgrading to 3.4.x version?
Cause
After upgrading to 3.4.x and going to IBM TRIRIGA Console -> Agent Manager, I cannot see anymore CleanupAgent entry available.
Answer
Starting with 3.4 version, CleanupAgent has changed name to PlatformMaintenanceScheduler (Platform Maintenance Scheduler) that fits better to what this agent will be really in charge of.
This agent conducts data cleanup and runs an analysis on the database. This agent removes all data in the state of null, and removes DataConnect (DC) jobs and staging table entries that are obsolete or completed. This agent also cleans up the completed workflow instances that do not have any user-operable tasks (such as user tasks and approval tasks) within the workflow.
See as well that the IBM TRIRIGA Admin Console “Cleanup Agent Manager” has changed to “Platform Maintenance Scheduler”.
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Document Information
Modified date:
17 June 2018
UID
swg21961270