Troubleshooting
Problem
Tivoli Storage Productivity Center 5.2.x users monitoring large environments may encounter DB2 transaction log full errors if small values for the DB2 parameters LOGFILSIZ, LOGPRIMARY, LOGSECOND, LOGBUFSZ are used, particularly when performance monitors are scheduled to run every minute.
Symptom
The problem can surface in Tivoli Storage Productivity Center in a variety of ways. It may be a failed upgrade, a failed action (e.g. deleting a storage system), a failed probe, or a variety of other issues. Investigation into the Tivoli Storage Productivity Center and DB2 logs provides confirmation of this condition.
Cause
The DB2 parameters for the transaction logs prior to Tivoli Storage Productivity Center 5.2.7 were set to default values deemed too small and can be increased.
Diagnosing The Problem
The Tivoli Storage Productivity Center logs will display the SQL errors:
SQLCODE=-964, SQLSTATE=57011
The db2diag log file will show:
"Log File has reached its saturation point"
DIA8309C Log file was full.
Resolving The Problem
Users experiencing this should upgrade to Tivoli Storage Productivity Center 5.2.7 or higher or modify the values for the following DB2 parameters:
LOGFILSIZ, LOGPRIMARY, LOGSECOND, LOGBUFSZ
Steps to check and modify the DB2 parameters:
- Open a DB2 command window:
- Run the following command to verify that the current values of the mentioned DB2 parameters are lower than the ones indicated at step 3.
db2 get db cfg for tpcdb > tpcdb_cfg_current.txt
- Open file tpcdb_cfg_current.txt and search for LOGFILSIZ, LOGPRIMARY, LOGSECOND, LOGBUFSZ
- If they are smaller than 20000, 100, 150, 512 then run step 5.
- Issue the following commands, one by one in this specific order, to increase the DB2 parameters:
db2 update db cfg for tpcdb using LOGFILSIZ 5000
db2 update db cfg for tpcdb using LOGSECOND 240
db2 update db cfg for tpcdb using LOGPRIMARY 16
db2 update db cfg for tpcdb using LOGBUFSZ 512
Note: You must ensure there is adequate disk or file system space before you modify the LOGFILSIZ, LOGPRIMARY, and LOGSECOND parameters. These values will result in approximately 5 GB of log file space.
The values suggested here will be the default values with Tivoli Storage Productivity Center 5.2.7
If the DB2 transaction log full errors continue after increasing these parameters as suggested or upgrading to Tivoli Storage Productivity Center 5.2.7 or higher, contact IBM Support for further investigation.
Was this topic helpful?
Document Information
Modified date:
22 February 2022
UID
swg21960971