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Tivoli Storage Manager server fails to start with SQL0290N SQLSTATE=55039

Troubleshooting


Problem

Startup of server can fail with SQL0290N SQLSTATE=55039 errors

Symptom

You may see the following output when starting server in the foreground:



    ANR0162W Supplemental database diagnostic information: -1:55039:-290
    ([IBM][CLI Driver][DB2/AIX64] SQL0290N Table space access is not allowed.
    SQLSTATE=55039).
    ANR3614E The server failed to connect to the database.

You may see the following in the db2diag.log at the time of startup failure

    2015-06-10-16.57.22.375656-240 E341827A662        LEVEL: Warning
    PID     : 10682420             TID  : 13880       PROC : db2sysc 0
    INSTANCE: tsmprd2              NODE : 000         DB   : TSMDB1
    APPHDL  : 0-7                  APPID: *LOCAL.tsmprd2.150610205340
    AUTHID  : TSMPRD2
    EDUID   : 13880                EDUNAME: db2redow (TSMDB1) 0
    FUNCTION: DB2 UDB, buffer pool services, sqlbReadPage, probe:1199
    MESSAGE : ADM6006E  DB2 encountered an error while reading page "2077720"
    from table space "5" for object "5" (located at offset "2077752" of
    container "/tsmprd2db/tsmdb001/tsmprd2/NODE0000/TSMDB1/T0000005/C0000000.LRG").

    2015-06-10-16.57.22.376330-240 I342490A538        LEVEL: Severe
    PID     : 10682420             TID  : 13880       PROC : db2sysc 0
    INSTANCE: tsmprd2              NODE : 000         DB   : TSMDB1
    APPHDL  : 0-7                  APPID: *LOCAL.tsmprd2.150610205340
    AUTHID  : TSMPRD2
    EDUID   : 13880                EDUNAME: db2redow (TSMDB1) 0
    FUNCTION: DB2 UDB, data management, sqldRedo, probe:7601
    RETCODE : ZRC=0x8402008F=-2080243569=SQLB_READERR
              "Non-critical I/O or verification error encountered during page
              read from disk."

Cause

There are one or more tablespaces in Rollforward Pending state

Diagnosing The Problem

To verify this is your problem, do the following:

1) Logon with the Tivoli Storage Manager server instance userid
2) Issue the "db2 list tablespaces show detail" command

You will see something similar to the following:


    Tablespace ID = 2
    Name = YOURSPACE1
    Type = Database managed space
    Contents = All permanent data. Large table space.
    State = 0x0080
    Detailed explanation:
    Roll forward pending

If you see output similar to this example, then this technical document and solution may resolve your problem.

Resolving The Problem

To resolve the problem, do the following

1) Logon with the Tivoli Storage Manager server instance userid.
2) For any tablespaces you see in RollFroward Pending state, use the "db2 rollforward" command to clear the Pending state.
3) Assuming the transaction logs are complete and healthy, the tablespace can be rolled back to normal using the following command :


    db2 "rollforward database tsmdb1 to end of logs and complete tablespace (yourspace1) online"

Notes :

- Specify the correct tablespace name based on the above command. The tablespace name is listed in the "db2 list tablespaces show detail" command output.

- You can use the "db2 list utilities show detail" command to monitor the rollforward progress.

4) Once the db2 rollfoward process completes for all affected tablespaces, the server should now start

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21959893