IBM Support

Cannot connect to Engine DB when trying to log into multiple IBM Datacap 9 applications

Troubleshooting


Problem

Users are attempting to log in but cannot. Rulerunners are running and processing batches. Users can log in to one application but not another at the same time

Symptom

"Cannot connect to Engine DB"

Cause

Multiple engine Databases that have the same db_index, cause locking issues when more than one application is launched

Diagnosing The Problem

Review Datacap Server logs for indications of:
12/16/13 15:14:37.862 2 12dc Database ID 'Admin' is duplicated for 'PROVIDER=MSSQL;DSN=sqlserver;CATALOG=FlexAdm;UID=myuser;PWD=******;DBNTA=;' and 'PROVIDER=MSSQL;DSN=sqlserver;CATALOG=APTAdm;UID=myuser;PWD=******;DBNTA=;'. Thread: 12dc Database index 156 is the same for 'C:\Datacap\Flex\FlexAdm.mdb' and 'C:\Datacap\APT\APTAdm.mdb'. Thread: 8dc

Resolving The Problem

To resolve, do the following for each application running on the Taskmaster Server.

Open the admin database.
In the admininfo table, note the value of db_index.
If the value is a duplicate of the value used in a different admin database, change the value to any other random 3-digit number such that it is unique for this database.
Close the admin database and open the engine database.
In the engineinfo table, check the value of db_index and change it so that it is the same as the value in the admininfo table. In older versions, these two values had to match.  In newer versions, the two values do not have to match, but it is still good practice to minimize the possibility of conflicts.
If the value of db_index is changed, edit the queue table in the engine database and change the value of qu_admDB to the new value for all records.

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Document Information

Modified date:
26 September 2022

UID

swg21959318