IBM Support

Tivoli Storage Manager Linux Server Hanging with "BUG: soft lockup" Message

Troubleshooting


Problem

The following error is logged at the Linux server console. [] BUG: soft lockup - CPU#1 stuck for 67s! [dsmserv:XXXXX] []

Symptom

The message on the console cannot be cleared without a soft reboot.
The /var/log/messages will show the following message :

(time-date) stable kernel: INFO: task dsmserv:XXXX blocked for more than XXX seconds

Cause

The host version of Linux, while supported by the Tivoli Storage Manager server, does not support the version of the Lin_tape driver being used.

Resolving The Problem

While the problem occurs when the Tivoli Storage Manager server attempts to contact the storage devices, the problem is not caused by Tivoli Storage Manager. The problem arises from a downlevel version of the lin_tape driver.

Redhat 6.6 is supported by all current, supported versions of Tivoli Storage Manager. However, the lin_tape driver will intermittently cause problems for the kernel if not at a supported version for Linux 6.6.

If the server is running on Linux 6.6 and presenting with this issue, upgrade the lin_tape driver to version 2.9.6 or above,

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21957973