Troubleshooting
Problem
Backups on Windows platform may fail with ANS5250E message and RC 162
Symptom
During backup operations, the following error message may be returned:
ANS4251W System Writer file '<file name>'
ANS4251W System Writer file '<file name>': not found.
ANS5250E An unexpected error was encountered.
TSM function name : PrivObjEnumBack
TSM function : fioGetAttrib failed for file
'<C:\Program Files\Tivoli\TSM\baclient\adsm.sys\
VSS_STAGING\<hostname>\<IP>\<timestamp>\ASR\Writer.xml'
TSM return code : 162
TSM file : ..\..\common\winnt\psincrsubs.cpp (1306)
ANS1228E Sending of object '' failed.
ANS5280E Object enumeration from a file set or file list failed
The symptom can be seen either during a scheduled operation or manual backup.
Cause
The Tivoli Storage Manager return code "162" is indicative that the client tried to obtain information from the drive indicated, but was unable to do so. Usually, this happens when the account does not have sufficient rights.
The following article describes the situation:
http://msdn.microsoft.com/en-us/library/ms684190%28VS.85%29.aspx
Note these lines:
"A service that runs in the context of the LocalSystem account inherits the security context of the SCM. The user SID is created from the SECURITY_LOCAL_SYSTEM_RID value."
Further details can be found here:
http://technet.microsoft.com/en-us/library/cc782435%28WS.10%29.aspx
Note this line:
"You can set permissions for individual services by using Security Templates or the sc command."
Resolving The Problem
Contact the Windows Administrator for setting the permission on the backup account according to the MS technote mentioned.
After having corrected the permissions, proceed to reset the staging directory as follow:
1. Stop the Tivoli Storage Manager Client scheduler
2. Delete/rename the c:\adsm.sys staging directory
3. Restart the Tivoli Storage Manager client scheduler and repeat the backup operation
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Document Information
Modified date:
17 June 2018
UID
swg21920401