Troubleshooting
Problem
When running Integrity Checker, this error may be reported:
BMXAA0443E -- ERROR -- BMXAA0456E -- The following users should be removed from the security tables: groupuser because they are not Maximo users:
Cause
User IDs are referenced in the Maximo security tables, but the IDs are not registered as users in Maximo. Data for these users is in the GroupUser table, but there are no parent records in the MaxUser table. This inconsistency must be resolved.
Diagnosing The Problem
You can determine which user IDs are referenced in the Maximo security tables, but are not registered as Maximo users, by running this SQL query:
Select Distinct userid From groupuser Where userid not in (Select userid from maxuser)
Resolving The Problem
This issue can be resolved in several ways, including:
1. Using the Maximo USERS application, register the user in Maximo
2. Drop references to the specified user ID from the Maximo security tables with this SQL:
Delete From groupuser Where userid='<userid>'
2a. If multiple user IDs are listed in the error message, they can all be resolved with this SQL:
Delete From groupuser Where userid Not In (Select userid from maxuser)
After the changes are applied, run Integrity Checker in report mode in order to verify that the error is resolved and is no longer displayed.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21903435