IBM Support

ScheduledTaskHistory.xml failing to be updated with scheduled event

Troubleshooting


Problem

FlashCopy Manager Scheduler is unable to read or write to the file C:\Program Files\Tivoli\FlashCopyManager\ScheduledTasks

Symptom

ERROR: Could not read file
C:\Program Files\Tivoli\FlashCopyManager\ScheduledTasks
Invalid Date Time value.
There is an unknown word at index 20.

Cause

The Language settings for the logged on user is different than the Language settings within the Registry, causing the .xml file formatting to be inconsistent.

Diagnosing The Problem

Compare the Windows Regional Language settings with the Locale settings in the Windows Registry.

Go to Control Panel --> Region and Language

  • Take a screen shot of the tab "Formats"
  • Take a screen shot of the tab "Location"
  • Take a screen shot of the tab "Administrative"
  • From the Formats tab, click on the "Additional Settings" button. Take a screen shot of the tab "time"

Export the regional language settings from the registry:
Within the registry, select FILE --> EXPORT and then at the bottom, for the EXPORT RANGE, choose the SELECTED BRANCH and then enter the following registry key:
HKEY_CURRENT_USER\Control Panel\International

Delete the ScheduledTaskHistory.xml file. It will be recreated after the next scheduled event.

Resolving The Problem

If the ScheduledTaskHistory.xml file is corrupt, removing the file so that it is recreated will resolve the problem.

Compare the data collected in the 'Diagnosing' section; if the Language settings between the Local settings from the control panel and the registry entries are not matched, these should be synchronized. Log on as a user that has permissions to update the registry and set the Locale settings to the correct values so they will match with the values that are see in the control panel.

For example, if the Regional settings in the windows control panel are showing a value of Argentina Spanish (es-AR) but in the registry the locale is set to Spain Spanish (es-ES). This will cause the formatting for the time within the ScheduledTaskHistory.xml file to use "p.m." instead of "PM". When this format is read during the update of the ScheduledTaskHistory.xml file to record the scheduled event, it will see this discrepancy of the formatting and consider the file to be corrupt.

To correct this problem, log on to the machine with a user who has permission to update the registry and then update the Argentina Spanish settings so that the registry will be updated. Then delete the ScheduledTaskHistory.xml file so that it will be recreated using the regional formatting. Thereafter the file should be written and read correctly.

[{"Product":{"code":"SS36V9","label":"Tivoli Storage FlashCopy Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"FlashCopy Manager MMC Snapin and Base System Services","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.1;3.2;4.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21903096