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Configuration of SystemOut.log and trace.log file in WebSphere

Question & Answer


Question

How to adjust the size and number of history files for TSAAM WebSphere (WAS). It is slightly different for TSAAM version 3.2.2.x with WebSphere 6.1 and TSAAM 4.1.x with WAS 8.5.0.1

Cause

This document describes how the logfiles can be adjusted that are used by WAS and TSAAM

Answer

To configure the SystemOut.log and trace.log for TSAAM component and WAS you have to logon to the WebSphere console first.

The solution describes how to configure log and trace file TSAAM for version 3.2.2.x and 4.1 with WAS 6.1. and 8.5.0.1. The procedure is the same for both versions.



TSAAM 3.2.2.x and WebSphere Application Server 6.1
Open WAS console, usually: https://<server name>:9043/ibm/console
TSAAM 4.1 and WebSphere Application Server 8.5.0.1
Open WAS console, usually: https://<server>:16316/ibm/console/logon.jsp

SystemOut.log:
On the left expand "Troubleshooting" --> Logs and Traces -->server1 --> JVM Logs

Here you can adjust the maximum size of SystemOut.log, SystemErr.log and the number of historical files to keep


Increase maximum size for SystemOut.log to 10..20 MB and keep around 5 historical files.
The recommended size depends on the activity. In environments with high load the size can also be increased up to 50..100 MB. The best is to check the time frame that a file can hold and adjust the size and number of historical files to keep a history also for longer running events.
It is also possible to enter a time frame that should be kept in a single SystemOut.log file.

The SystemErr.log file size can also be increased up to 3 MB and/or increase number of historical files.


Save the changes to the Master Configuration.

In the runtime tab the full path to the logfiles can be seen.

trace.log:
When trace is activated the data is written to the trace.log. See technote
http://www-01.ibm.com/support/docview.wss?uid=swg21693091
For details to setup trace for TSAAM EEZ component
On the left expand "Troubleshooting" --> Logs and Traces -->server1 --> Diagnostic Trace

Change the file size and number of historical files as described above.
To reproduce a specific issue we recommend a maximum file size of 100 MB.
It can be reduced again afterwards to previous value.
Click "OK" and save to Master Configuration as well.

Then restart WebSphere to activate new settings
It is also possible to use the Runtime panel instead to make changes effective immediately. After WAS restart the values from the master configuration is used again. This is helpful if the problem does not require WAS restart.

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Document Information

Modified date:
17 June 2018

UID

swg21902513