IBM Support

Trouble shooting the tsmdlst command

Technote (troubleshooting)


Problem(Abstract)

How can problems with the tsmdlst command be investigated/traced/determined?

Symptom

Output from tsmdlst is not what is expected.


Cause

The data displayed by tsmdlst is obtained from the Windows registry, the registry contains unexpected entries or is missing entries.

Diagnosing the problem

The information in the tsmdlst output is obtained from the Windows registry, if problems are seen in the tsmdlst output the following steps can be performed to verify that tsmdlst is displaying the information correctly.

Verify the version of the tsmdlst executable (right click, Properties > Version) to ensure it is current.

Trace the tsmdlst command .

Commonly used traceflags:

/verbose /xinquiry /trace

tsmdlst /? will show detail on all options available to the command.

Collect the screen output and trace data, trace output is tsmdlst_trace.txt

2) Export the registry key below as a text file.

HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\

Review the registry information to verify it matches the tsmdlst output.


Resolving the problem

The tsmdlst output should match what is shown in the registry. If Windows is not providing accurate device information, Microsoft should be engaged to investigate and resolve the problem.

Product Alias/Synonym

TSM

Document information

More support for: Tivoli Storage Manager

Software version: All Supported Versions

Operating system(s): Windows

Reference #: 1902150

Modified date: 11 April 2017


Translate this page: