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ITCAM for Microsoft AD agent is not starting

Troubleshooting


Problem

When ITCAM for Active Directory agent is started, error KCICF5100E is displayed and the agent does not start.

Symptom

When agent is started using MTEMS panel, it shows following error:


Cause

The agent is unable to find an SSL transport library in agent path, and therefore the agent process fails to launch.

Environment

Windows

Diagnosing The Problem

Host_3z_k3zcma_<hex>-01.log in ITMHOME\TMAITM6_x64 shows following messages, indicating that SPIPE protocol is being used for connection with TEMS, and SSL interface module is unavailable:

...
(553A4BA4.039A-18D0:kbbssge.c,52,"BSS1_GetEnv") CT_CMSLIST="IP.SPIPE:#<tems-ipaddress>"
(553A4BA4.02C7-18D0:kdebprc.c,1306,"static_constructor") SSL interface module kdebe unavailable

...
(553A4BA6.06AD-18D0:kraaumsg.cpp,107,"CTRA_msg_no_transports") CTRA
Server: no transports available, ffffffff. Server shutting down

Resolving The Problem

Copy kdebe.dll from C:\IBM\ITM\TMAITM6_x64 to C:\IBM\ITM\GSK8_x64\lib64.

Start the agent.

Note:The same problem can occur for the ITCAM MSSQL Server agent, and the same resolution applies in that case.

[{"Product":{"code":"SSDKXQ","label":"Tivoli Composite Application Manager for Microsoft Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Active Directory Agent - 5724C71AO","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3.0;6.3.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21883865