IBM Support

Steps to manually uninstall Tivoli Storage Manager components on Windows

Troubleshooting


Problem

When the Tivoli Storage Manager fails to uninstall with run of "Uninstall Tivoli Storage Manager.exe" it is required to manually uninstall the components from Windows to cleanup the installation.

Symptom

Tivoli Storage Manager related programs still available in add remove programs and visible in services manager.

Cause

Corrupt or incomplete installation of previous Tivoli Storage Manager package

Environment

Tivoli Storage Manager server on windows

Resolving The Problem

Follow these steps to uninstall the Tivoli Storage Manager server failed installation:

1. Look for the IBM ADE service in Windows service manager and stop it.


2. Open a DOS window and perform a complete uninstall of the Deployment Engine by changing to directory ...\Program Files\IBM\Common\acsi\jre\bin.

From this directory run: "C:\Program Files\IBM\Common\acsi\bin\si_inst.bat" -r -f

Incase the uninstall fails with error as below :

C:\Program Files\IBM\Common\acsi\bin>si_inst.bat -r -f

ACUINI0026I Deployment Engine Uninstallation Failed!

Causes: com.ibm.ac.si.install.InstallException:;com.ibm.ac.si.runtime.lock.LockNotAllowedException:lock_not_allowed



Please run the below steps.

cd C:\program files\IBM\Common\acsi\logs

erase .lock*

cd C:\program files\IBM\Common\acsi

setenv

cd C:\program files\IBM\Common\acsi\bin

Run again si_inst.bat -r -f

You will get message as below :

ACUINI0004I UnInstallation completed successfully!
The file cannot be found in path specified


3. Run uninstall.exe in c:\program files\tivoli\tsm\_uninst


4. Check the add/remove programs. If any portions of the installation still exist, such as the Tivoli Storage Manager server, device driver and components related to the initial installation of Tivoli Storage Manager package, remove them.


5. Delete the following folders:

"c:\program files\tivoli\tsm\AC
"c:\program files\tivoli\tsm\console
"c:\program files\tivoli\tsm\db2
"c:\program files\tivoli\tsm\device
"c:\program files\tivoli\tsm\license
"c:\program files\tivoli\tsm\server
"c:\program files\tivoli\tsm\_uninst
"c:\program files\IBM\Common\acsi"


6. Reboot the Windows server


7. The DB2 related services are still expected to be existing in the server in spite of the components installation. Uninstall of DB2 does not remove DB2 services.


8. To cleanly uninstall DB2 run the following command:
Go to the <package Directory>\COI\PackageSteps\DB2_versionname\FILES

You will see 2 files in this directory : setup.exe and db2unins.bat

Run "db2unins -f"

This would force uninstall of the DB2 database product, which should remove any components/files that may have been causing problems.


9. Proceed with the reinstall / new install of the product as desired. The installation is expected to run smoothly.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21882929